Last modified: 2011-04-06 21:59:43 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28444 - Double click on old revision opens the current revision
Double click on old revision opens the current revision
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
JavaScript (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Brion Vibber
:
Depends on:
Blocks: javascript
  Show dependency treegraph
 
Reported: 2011-04-06 16:39 UTC by Danny B.
Modified: 2011-04-06 21:59 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2011-04-06 16:39:25 UTC
Double click on old revision used to open that old revision to edit. Now it opens the most recent.
Comment 1 Brion Vibber 2011-04-06 21:50:24 UTC
Looks like a regression in r61071 when the code was consolidated from the Skin and SkinTemplate classes; the $this->editUrlOptions() passed into the title->getEditUrl() got lost, dropping the oldid parameter.
Comment 2 Brion Vibber 2011-04-06 21:59:43 UTC
Fixed on trunk in r85583. Will need merging to 1.17.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links