Last modified: 2012-04-16 09:15:34 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 28228 - Resource Loader should use RTL layout when user wants it, not site
Resource Loader should use RTL layout when user wants it, not site
Status: RESOLVED DUPLICATE of bug 6100
Product: MediaWiki
Classification: Unclassified
ResourceLoader (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Trevor Parscal
: i18n
Depends on:
Blocks: 24692
  Show dependency treegraph
 
Reported: 2011-03-24 23:52 UTC by Neil Kandalgaonkar
Modified: 2012-04-16 09:15 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Neil Kandalgaonkar 2011-03-24 23:52:18 UTC
It seems that Resource Loader will send RTL CSS files only if LocalSettings.php has $wgLanguageCode set to be a known RTL language, like 'ar' or 'he' or 'enrtl'.

That works fine for the Wikipedias, which are monolingual. 

But a site like Commons is multilingual. People should be able to use a different interface based only on their language preference, or even the uselang= parameter.
Comment 1 DieBuche 2011-04-21 14:16:30 UTC

*** This bug has been marked as a duplicate of bug 27490 ***
Comment 2 Neil Kandalgaonkar 2011-04-21 18:07:58 UTC
This is not a duplicate of bug 27490. The fix to bug 27490 is in fact what introduced the problem.

UploadWizard is all user interface, there's no long continuous text. Hence it's messed up, just as the fix to the bug admits.

You will note that this bug was filed months after the patches to fix the other bug landed.
Comment 3 Mark A. Hershberger 2011-05-15 17:28:39 UTC
Would Bug #28994 help out here?
Comment 4 Mark A. Hershberger 2011-05-15 17:29:52 UTC
Sorry, I meant Bug #6100.
Comment 5 Robin Pepermans (SPQRobin) 2011-06-24 21:33:48 UTC

*** This bug has been marked as a duplicate of bug 6100 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links