Last modified: 2011-10-03 05:10:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27889 - Tidy fails silently if missing, documentation out of date
Tidy fails silently if missing, documentation out of date
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.18.x
All All
: Normal critical with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
http://translatewiki.net/w/i.php?titl...
:
Depends on:
Blocks: tidy
  Show dependency treegraph
 
Reported: 2011-03-06 10:29 UTC by Niklas Laxström
Modified: 2011-10-03 05:10 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Niklas Laxström 2011-03-06 10:29:42 UTC
The following input is not fixed and causes page layout to explode:

 <big><big><big>ܫܠܡܐ ܘܐܝܩܪܐ
<big><big>Hello!
 <big><big>اهلا وسهلا

In the source code it reads:
<!-- Tidy found serious XHTML errors -->
Comment 1 Siebrand Mazeland 2011-03-06 11:25:31 UTC
URL updated.
Comment 2 Niklas Laxström 2011-03-06 11:28:56 UTC
Not a regression. Started happening after we moved to a newer server with newer PHP.
Comment 3 Platonides 2011-03-06 15:34:18 UTC
Works for me with external tidy, version 25 March 2009.

Can be tested with:
<?php
/* Bug 27889 */
require_once( "maintenance/commandLine.inc" );
echo MWTidy::tidy("<big><big><big>ܫܠܡܐ ܘܐܝܩܪܐ
<big><big>Hello!
 <big><big>اهلا وسهلا");

I get
<p><big><big><big>ܫܠܡܐ ܘܐܝܩܪܐ <big><big>Hello! <big><big>اهلا وسهلا</big></big></big></big></big></big></big></p>
Comment 4 Niklas Laxström 2011-03-06 16:01:11 UTC
Meeh. MediaWiki doesn't warn if tidy isn't installed.
Comment 5 Sam Reed (reedy) 2011-03-06 16:01:47 UTC
(In reply to comment #4)
> Meeh. MediaWiki doesn't warn if tidy isn't installed.

That sounds like a bug..
Comment 6 Platonides 2011-03-06 16:06:32 UTC
If you didn't have Tidy, where did 'Tidy found serious XHTML errors' message came from?
Comment 7 Niklas Laxström 2011-03-06 16:09:43 UTC
Now when I installed libtidy and the PHP module with pecl install tidy (not with *pear* as it says everyhere) I get:

Fatal error: Class 'tidy' not found in /www/sandwiki/includes/parser/Tidy.php on line 195
Comment 8 Niklas Laxström 2011-03-06 16:14:42 UTC
Okay, the PECL is for PHP 4.x only. tidy is now bundled with PHP5 and I can't find any in PEAR. Documentation needs also updating.
Comment 9 Aaron Schulz 2011-09-27 17:22:16 UTC
(In reply to comment #8)
> Okay, the PECL is for PHP 4.x only. tidy is now bundled with PHP5 and I can't
> find any in PEAR. Documentation needs also updating.

What still needs updating?
Comment 10 Niklas Laxström 2011-09-28 15:11:58 UTC
Docs how to install tidy, and have MW complain instead of failing silently?
Comment 11 Aaron Schulz 2011-09-28 15:20:45 UTC
There were some changes back in r92106.
Comment 12 Aaron Schulz 2011-09-28 15:32:30 UTC
(In reply to comment #10)
> Docs how to install tidy, and have MW complain instead of failing silently?

MW.org? Manual:$wgTidyInternal and Manual:$wgTidy seem OK now.
Comment 13 Niklas Laxström 2011-10-03 03:39:40 UTC
If you think it's fixed, please close this bug. I'm not going to build an environment without tidy to test this.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links