Last modified: 2014-01-04 10:17:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 27744 - Add the neuter gender
Add the neuter gender
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
Internationalization (Other open bugs)
1.18.x
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: i18n
Depends on:
Blocks: gender
  Show dependency treegraph
 
Reported: 2011-02-26 17:03 UTC by Purodha Blissenbach
Modified: 2014-01-04 10:17 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Purodha Blissenbach 2011-02-26 17:03:51 UTC
Currently, we have gender support for
- the male gender
- the female gender
- gender unknown (although caguely attributed "neutral" in the code sometimes)

Many germanic languages, including English, require the neuter gender at times, such as when having to make a distinction between:
- (Missis Smith) "she"
- (Mister Miller) "he"
- (a bot program, a person nicknamed by a word of neuter gender) "it"

Gender agnostic wordings such as "user xyzzy" fits them all and is not outright
wrong in the neuter gender case, but having the correct grammatical gender at
hand even in these comaparatively rare cases will be much better language use.
Comment 1 Bawolff (Brian Wolff) 2011-02-26 21:14:36 UTC
related Bug 25834
Comment 2 Niklas Laxström 2011-08-18 15:21:14 UTC
Would this only be used for bots?
Comment 3 p858snake 2011-08-19 02:20:33 UTC
(In reply to comment #2)
> Would this only be used for bots?
There are people that don't identify to a gender (or to the normal gender identities).

Which is what we try to keep our unspecified/undisclosed as (or at least should be doing)
Comment 4 Purodha Blissenbach 2011-08-19 07:36:07 UTC
(In reply to comment #2)
> Would this only be used for bots?

No.
As said above, Nicknames of neuter grammatical gender may require it, too. This includes, for instance all diminiutives of names such as "Maria" (Mary, feminine) -> "Mariechen" (little Mary, neuter) for all local languages of the western part of the West German continuum from Swiss German over Swabian, Alsation, Palatinean, Ripuarian, (East) Limburgish to Low German (including Westphalian)

Usage is depending on language. It would not be used for bots having Names of non-neuter grammatical gender in Colognian, e.g.


Off-Topic:
As a side-note: it may be useful to make user "right" or group or status information available to message handling occasionally. We translate a user name to the string "the user named 'xyzzy'" in cases of unknown gender, since articles must be used with names standing alone, and there is no genderless article. It would of course be both clearer and more informative to use "the bot named 'xyzzybot'" instead. With some log messages, we would have take care to keep the status at the time of logging, then.

Another side-note: In order to get nicknaming with grammatically gendered words right, we would need to know both grammatical and natural gender. For example, a male boxer nicknamed "the Ape" ("Ape" is feminine as per grammatical gender) hit his father in law K.O. -> newspaper headline: "Die Aap hät singe Schwejervatter verkammesölt!" -> Grammatical analysis: "The Ape (feminine) is referred to with "his" (masculine) -> The nick's article goes the nicknames grammatical gender while references to the person otherwise go with the natural gender.

Yet another side note: It is not uncommon, that people use Nicknames that include articles, such as ":w:de:User:Der Hexer" or ":w:de:User:De Uli". For languages that require articles to be used with names, we have those articles in messages files  of course. At least for the langues I know, adding Articles should be avoided, when names already contain ones.
Comment 5 Purodha Blissenbach 2011-08-19 07:45:48 UTC
(In reply to comment #3)
> There are people that don't identify to a gender (or to the normal gender
> identities).
> 
> Which is what we try to keep our unspecified/undisclosed as (or at least should
> be doing)

Not to select a gender, whatever the cause, is possible.
To the best of my knowledge "unspecified" is not posing any grammatical or other
problems in the context of multiple language support (i18n).
Comment 6 Purodha Blissenbach 2011-09-23 09:58:22 UTC
Another context requiring the neuter gender surfaced in a radio interview with one of 15 members of the German Pirate Party, who were recently elected into the Berlin federal state parliament. The interviewed person is well known with his nick Plaetzchen (cookie) and confessed that he likes eating cookies, hence the name. Asked whether he wanted to be addressed "Mr. Cookie" or just "cookie" he said "das Plaetzchen" (the cookie) - "das" being the neuter article in German grammar.

Standard German does not put grammatical articles in front of names usually, but many regional and local varieties do. Having articles in front of names of processes, jobs, or bots, and some nick names, is at least established jargon, dispersing into standard language use through computer magazines, and other press. Grammatical articles always convey grammatical gender. German has three of them.

Analysis:

We have:
- natural gender: "male", "female", "undisclosed", ("other" being discussed)
We need in addition:
- grammatical gender: "masculine", "feminine", "neuter"
- use article before name: "yes", "no"

so as to be able to completely map German language use in our German L10n.


Btw. the German Pirate Party is running a MediaWiki wiki. Das Plätzchen is of course using it.
Comment 7 Niklas Laxström 2011-09-23 10:00:52 UTC
Interesting story. Adding neuter gender (different from unspecified) is probably the next step we will do at some point.
Comment 8 p858snake 2011-09-23 10:05:11 UTC
undisclosed (what unspecified is now called) should already be a gender neutral for the languages that support it...
Comment 9 Niklas Laxström 2011-09-23 10:08:19 UTC
(In reply to comment #8)
> undisclosed (what unspecified is now called) should already be a gender neutral
> for the languages that support it...

Not really, many languages default to masculine form instead of grammatical neuter.
Comment 10 Purodha Blissenbach 2011-09-23 10:34:22 UTC
(In reply to comment #8)
> undisclosed (what unspecified is now called) should already be a gender neutral
> for the languages that support it...

That is not so. For most Germanic languages that I am aware of, the actual use is not compatible with the neuter Gender. You need to be aware that quite often, grammatical and natural gender deviate from each other, and while the natural gender governs the genderized use of very many languages in the world, this is not so for a large number of Indo-European languages, most notably Germanic ones.

In addition to what Niklas Laxström wrote, we also have at least one language that does not have a true default, and thus resorts to constructs like "the user named X..." which does not imply a gender. While this fits for neuter, too, it is definitely not the way you would talk about a neuter.
Comment 11 Siebrand Mazeland 2012-10-16 11:21:30 UTC
Without wanting to seem insensible to those of undetermined gender, wanted or unwanted, I am closing this issue as WONTFIX.
Comment 12 Bawolff (Brian Wolff) 2012-10-16 16:09:19 UTC
(In reply to comment #11)
> Without wanting to seem insensible to those of undetermined gender, wanted or
> unwanted, I am closing this issue as WONTFIX.

? Usually things get wontfixed because
a) It is infeasible to do. That does not appear to be the case.
b) It is a "bad idea". The comments so far don't really seem to indicate that that is the case

So why the wontfix?
Comment 13 Nemo 2014-01-04 09:53:31 UTC
*** Bug 59643 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links