Last modified: 2011-02-07 11:07:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26827 - User cannot insert any commands by clicking on the wiki buttons on toolbar in Internet explorer browsers
User cannot insert any commands by clicking on the wiki buttons on toolbar in...
Status: CLOSED FIXED
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
1.17.x
PC Windows XP
: Normal blocker (vote)
: ---
Assigned To: Trevor Parscal
:
: 26825 (view as bug list)
Depends on:
Blocks: 26611
  Show dependency treegraph
 
Reported: 2011-01-21 06:11 UTC by Nadeesha
Modified: 2011-02-07 11:07 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nadeesha 2011-01-21 06:11:47 UTC
Steps to reproduce
1. Open a wiki page in edit mode(IE7 or IE8).
2. Click on the any button available on wiki toolbar

Actual Result
User cannot insert commands into the wiki editor.

Expected result
User should be able to insert commands into the wiki editor.


URL : http://prototype.wikimedia.org/rc-en/index.php/Main_Page
Version : 1.17alpha (r80667)
Comment 1 Mark A. Hershberger 2011-01-21 16:39:56 UTC
1.17 blocker for Trevor
Comment 2 Brion Vibber 2011-01-22 04:11:22 UTC
Testing in IE 8 on Windows 7: error is 'object doesn't support this property or method' blah in this bit of jquery.textSelection.js:

if(context){
context.fn.restoreStuffForIE();
}

It looks like no restoreStuffForIE function ever gets defined, so this may be a leftover of code that's been moved or dropped.
Comment 3 Brion Vibber 2011-01-24 01:50:59 UTC
*** Bug 26825 has been marked as a duplicate of this bug. ***
Comment 4 Roan Kattouw 2011-01-24 02:58:47 UTC
(In reply to comment #2)
> Testing in IE 8 on Windows 7: error is 'object doesn't support this property or
> method' blah in this bit of jquery.textSelection.js:
> 
> if(context){
> context.fn.restoreStuffForIE();
> }
> 
> It looks like no restoreStuffForIE function ever gets defined, so this may be a
> leftover of code that's been moved or dropped.
Yes, it's a leftover of that function being renamed and callers not having been updated. Should be fixed in r80842.
Comment 5 Nadeesha 2011-01-27 10:08:35 UTC
Re-opening the bug.
Comment 6 Nadeesha 2011-02-07 11:07:56 UTC
Closing the bug

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links