Last modified: 2011-11-02 15:29:13 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26673 - getPrefixedText called on a non-object during XML dump production
getPrefixedText called on a non-object during XML dump production
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
LiquidThreads (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://dumps.wikimedia.org/ptwikibook...
:
Depends on:
Blocks: 17553 27642
  Show dependency treegraph
 
Reported: 2011-01-11 22:07 UTC by Ariel T. Glenn
Modified: 2011-11-02 15:29 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ariel T. Glenn 2011-01-11 22:07:26 UTC
Fatal error: Call to a member function getPrefixedText() on a non-object in /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads/classes/Hooks.php on line 180

Seen when dumping page stubs; this therefore breaks all page text dumps as well. 

Reedy pointed to this revision as the guilty party:
http://www.mediawiki.org/wiki/Special:Code/MediaWiki/68594
Comment 1 Helder 2011-03-06 13:40:03 UTC
(In reply to comment #0)
> Fatal error: Call to a member function getPrefixedText() on a non-object in
> /usr/local/apache/common-local/wmf-deployment/extensions/LiquidThreads/classes/Hooks.php
> on line 180

This seems to be related to (or the cause for) Bug 27642. The latest dump[1] has exactly the same error:
http://dumps.wikimedia.org/ptwikibooks/20110111/
Comment 2 Ariel T. Glenn 2011-07-23 08:28:00 UTC
And this error is still around... see http://dumps.wikimedia.org/ptwikibooks/20110722/
Comment 3 Helder 2011-08-13 15:20:36 UTC
Marking as major since this is affecting various dumps on Portuguese Wikibooks (bug 27642).
Comment 4 Ariel T. Glenn 2011-09-18 08:15:32 UTC
Roan put in a quick hack to avoid the fatal, see r1=95668&r2=97140&pathrev=97140">http://svn.wikimedia.org/viewvc/mediawiki/branches/wmf/1.17wmf1/extensions/LiquidThreads/classes/Hooks.php?r1=95668&r2=97140&pathrev=97140  and the dumps now run to completion.  Whether there is some underlying cause that needs to be checked, is another matter entirely...
Comment 5 Ariel T. Glenn 2011-11-02 15:29:13 UTC
That fix appears to have done the trick, runs for ptwikibooks have been good since then.  Closing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links