Last modified: 2013-06-18 16:29:23 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26405 - MediaWiki:Categorytree-member-num should show count of files, subcategories and pages
MediaWiki:Categorytree-member-num should show count of files, subcategories a...
Status: RESOLVED DUPLICATE of bug 29357
Product: MediaWiki extensions
Classification: Unclassified
CategoryTree (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://translatewiki.net/wiki/Thread:...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-23 21:17 UTC by The Evil IP address
Modified: 2013-06-18 16:29 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description The Evil IP address 2010-12-23 21:17:37 UTC
The message http://translatewiki.net/wiki/MediaWiki:Categorytree-member-num/en currently only shows the count of subcategories, which is only partially helpful when browsing subcategories. Most wikis have already tweaked this message with the ParserFunctions extension to show the number of subcats, files and pages if there are any, or "empty" if they don't exist (see URL for links). I believe that the message would also be useful like this by default, because it's quite some useful information to see the number of pages and files, too. Since ParserFunctions are an extension, the ifs would have to be done in the PHP code, probably by using different messages depending on if the specific groups have members.
Comment 1 Bawolff (Brian Wolff) 2010-12-24 05:20:34 UTC
Just to see if I understand this bug, are you proposing a new value for mediawiki:categorytree-member-num (say $6) that says:

"Empty" if the category has 0 files, 0 subcats, and 0 pages

Otherwise a comma separated list of the counts, something like "4 files, 10 categories, 12 pages" (committing any item that is 0)

(With empty, $1 pages,  $1 categories and  $1 files being their own messages).

Is that correct?
Comment 2 comport 2010-12-24 09:42:30 UTC
http://translatewiki.net/wiki/Thread%3ASupport/MediaWiki%3ACategorytree-member-num

http://www.mediawiki.org/wiki/Extension:CategoryTree#categorytree-member-num

The default value of this message is ($5) (see links above)

If translator on translatewiki.net use values $1, $2, $3, $4 in this message, displaying error: !!FUZZY!! 
*Non-complete translate
* $5 do not use
* $4, $1, $2, $3, $2, $1, $2, $2, $3, $3 unknown (possible variants)

And then this message is excluding from MediaWiki updating.

And then each local project use personal variant of this message.
Comment 3 Bugmeister Bot 2011-08-19 19:12:24 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 4 Bawolff (Brian Wolff) 2012-07-24 12:35:51 UTC
Didn't this get fixed?
Comment 5 Bawolff (Brian Wolff) 2012-07-24 12:38:11 UTC
yes, bug 29357

*** This bug has been marked as a duplicate of bug 29357 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links