Last modified: 2011-02-01 05:59:37 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 26041 - simple search displays list twice
simple search displays list twice
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://commons.prototype.wikimedia.or...
:
Depends on:
Blocks: 26611
  Show dependency treegraph
 
Reported: 2010-11-21 20:28 UTC by Thomas Bleher
Modified: 2011-02-01 05:59 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screenshot showing the problem (133.38 KB, image/png)
2010-11-21 20:28 UTC, Thomas Bleher
Details

Description Thomas Bleher 2010-11-21 20:28:15 UTC
Created attachment 7845 [details]
Screenshot showing the problem

When simple search (from the Vector extension) is enabled, the suggestion box is displayed twice (in different locations on the screen, apparently partially depending on the size of the window). See attached screenshot.

I have reproduced this issue on the current SVN version (both MediaWiki itself and the Vector extension were up-to-date). It can also be seen on the commons prototype page.

This is using Chromium 6.0.472.63~r59945-2 as shipped with current Debian Testing.
Comment 1 Sam Reed (reedy) 2011-01-11 01:57:24 UTC
This is WFM on Google Chrome 10.0.628.0 dev. Same on FF 3.6.13

Granted, you are using Debian Testing, so things are going to be rather out of date...

http://en.wikipedia.org/wiki/Google_Chrome#Release_history

6 and even 7 are listed as "old releases"
Comment 2 Thomas Bleher 2011-01-11 06:29:09 UTC
I agree that Chromium 6 is not the newest version, but it will be shipped with Debian Squeeze, so it will be around until the release of Wheezy, which is at least two years into the future.

The problem described in the bug also shows up in IceWeasel 3.5.16-3, which is also in Debian Testing.

I do hope that Wikipedia will continue to work with these "older" browsers - after all even IE6 is still mostly supported, so these are not too old. It would be a real pity if no browser in the upcoming Debian release could properly display Wikipedia.
Comment 3 Trevor Parscal 2011-01-11 18:16:55 UTC
Our policy is to support any browser which has significant (>=0.1%) market share (backward compatible), and the most recent version of any browser which has a significant market share across versions (forward compatible). Anything beyond that is a bonus.

http://stats.wikimedia.org/wikimedia/squids/SquidReportClients.htm

As of today...

Chrome 2.0 ------ 718 -- 0.02%
Chrome 3.0 ---- 1,997 -- 0.04%
Chrome 4.0 ---- 2,927 -- 0.07%
Chrome 4.1 ---- 2,149 -- 0.05%
Chrome 5.0 --- 10,899 -- 0.24%
Chrome 6.0 -- 397,098 -- 8.88%
Chrome 7.0 --- 15,967 -- 0.36%
Chrome 8.0 ---- 1,350 -- 0.03%

According to this we should be officially supporting Chrome 5, 6, 7 and 8.
Comment 4 Mark A. Hershberger 2011-01-20 19:07:36 UTC
So, Trevor, any chance of this being addressed in the next week?
Comment 5 Brion Vibber 2011-01-22 01:52:31 UTC
If I'm not mistaken, this is the result of both the old-school 'mwsuggest' and the newer vector simplesearch drop-downs being active at the same time.

(With Firefox 4b9 (Ubuntu 10.10 x86_64), I see them both but they show in the same physical area on screen, so depending which one comes up first you might not notice the second one.)

The site probably just needs to set:

$wgEnableMWSuggest = false;

Or is SimpleSearch supposed to degrade automatically to the internal mwsuggest?
Comment 6 Mark A. Hershberger 2011-01-22 02:00:03 UTC
Thomas,

Since this is a blocker and Brion has suggested what sounds like a reasonable explanation.  I'm closing this.  Feel free to re-open if you try 

$wgEnableMWSuggest = false;

and still see the problem.
Comment 7 Thomas Bleher 2011-01-22 07:01:55 UTC
Thanks! It works when I disable MWSuggest.

It should probably be documented somewhere that SimpleSearch and MWSuggest are incompatible. Particularly as it worked in earlier versions, so people doing upgrades should somehow be notified.

You should also probably note somewhere to set

$wgEnableMWSuggest = false;

before deploying the new MediaWiki code to Wikipedia.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links