Last modified: 2014-02-28 20:51:38 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 24859 - Redirect to mobile gateway should be handled on the server-side rather than the client-side
Redirect to mobile gateway should be handled on the server-side rather than t...
Status: RESOLVED FIXED
Product: Wikimedia Mobile
Classification: Unclassified
WAP mobile gateway (Other open bugs)
--
All All
: Normal normal with 1 vote (vote)
: ---
Assigned To: Asher Feldman
:
Depends on:
Blocks: 27257
  Show dependency treegraph
 
Reported: 2010-08-18 19:21 UTC by Ryan Kaldari
Modified: 2014-02-28 20:51 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ryan Kaldari 2010-08-18 19:21:30 UTC
Right now redirecting mobile users to *.mobile.wikipedia.org is handled by client-side Javascript. Ideally, the redirect should be handled on the server-side (probably by the squid servers or whatever directs requests to the squid servers).

This will make it easier to fix bugs like Bug 23554.
Comment 1 Derk-Jan Hartman 2010-08-18 21:47:11 UTC
See also http://www.mail-archive.com/squid-users@squid-cache.org/msg70245.html
Comment 2 Tomasz Finc 2010-08-20 23:40:21 UTC
Issue has been raised with the ops team. Waiting to hear back to determine action plan.
Comment 3 Ryan Kaldari 2010-08-21 01:23:57 UTC
Comment from Brion Vibber (via Wikitech-l):
What would be required would be some filtering in the caches to check for particular User-Agents or other settings and send them the redirect directly, or send them through to PHP for possible redirection. (Assuming there's no problem with downstream caching, which I think should usually be ok the way we have things marked -- as long as the redirect responses are marked as private-cache or uncacheable.)
Comment 4 Derk-Jan Hartman 2010-09-04 13:08:47 UTC
Another config example: http://en.positon.org/post/Squid-26-redirection

The problem is of course that the cookie value needs to be taken into account. Apparently 

http://www.squid-cache.org/mail-archive/squid-users/200703/0129.html

might make that possible.
Comment 5 Tomasz Finc 2010-09-08 18:57:32 UTC
(In reply to comment #2)
> Issue has been raised with the ops team. Waiting to hear back to determine
> action plan.

RT ticket open about this issue: http://rt.wikimedia.org/Ticket/Display.html?id=196 . 

In the meantime we might be able to do the redirect within the resource loader to make the experience a bit faster.
Comment 6 Ryan Kaldari 2010-09-08 19:09:50 UTC
According to Trevor the Resource Loader won't be deployed until mid-November or so. (I'm guessing December.)
Comment 7 Derk-Jan Hartman 2011-02-16 21:23:05 UTC
Now that the Resource Loader is deployed, this should get much higher priority.

Mobile devices now have to load the entire page, before the mobile redirect script is executed. Making the whole exercise pretty useless, and probably some older devices, won't even reach the bottom of the page.
Comment 8 Tomasz Finc 2011-05-10 18:17:36 UTC
This is going to be taken care of by the mobile rewrite port. Marking as defendant on Bug #25558.
Comment 9 Tomasz Finc 2011-07-27 21:36:38 UTC
Looks like were not blocked on the new extension anymore. Thanks to Asher and Patrick we have a list of ACL's that can go directly in to squid. Early production tests picked up more user agents then they should have but we've fixed that up. Production push will be posted on http://wikitech.wikimedia.org/view/Software_deployments as soon as its ready.
Comment 10 Tomasz Finc 2011-07-29 19:06:11 UTC
Were doing one box testing on the squids right now. If all goes well were aiming to do a full ACL deploy early next week.
Comment 11 Derk-Jan Hartman 2011-07-29 19:59:21 UTC
Wicked. That will be a nice step forward.
Comment 12 Tomasz Finc 2011-08-02 21:19:06 UTC
Were still tweaking our regexes so that we don't catch things like API request to EN wiki. If you have any questions send them over to binasher on irc.
Comment 13 Asher Feldman 2011-08-05 19:02:22 UTC
The mobile redirect is now being handled by our frontend squids, which are now picking a much larger set of devices.  Long live the javascript redirect!

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links