Last modified: 2010-07-22 12:01:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23770 - Incorrect set of characters for Arabic special characters toolbar
Incorrect set of characters for Arabic special characters toolbar
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal trivial (vote)
: ---
Assigned To: Roan Kattouw
:
Depends on:
Blocks: 24493
  Show dependency treegraph
 
Reported: 2010-06-03 08:33 UTC by Huji
Modified: 2010-07-22 12:01 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Huji 2010-06-03 08:33:07 UTC
The set of characters provided under the special characters toolbar for "Arabic" are not correct:

1) They include پ and چ and ژ and گ which are not Arabic; they are used in Persian language only.

2) If it was intended to merge Arabic and Persian special chars into one category, then they don't included other characters required in Persian language, including the correct Persian Yeh (ی) and Zero-Width-Non-Joiner.

Given that the order of letters is different in Arabic and Persian, and with the aforementioned reasons, I suggest Arabic and Persian are served as two separate sections.
Comment 1 Roan Kattouw 2010-06-03 09:06:42 UTC
Could you tell us which characters (and in which order) should appear in the Arabic and Persian sections?
Comment 2 Huji 2010-07-02 14:14:59 UTC
Sorry I didn't reply sooner (for some reason, my email subscription has ended up in spam folder!)

The correct set of Arabic characters (letters) is available here: http://en.wikipedia.org/wiki/Template:Arabic_alphabet

The correct set of Persian characters (letters) is available here: http://en.wikipedia.org/wiki/Template:Persian_alphabet

Other than these, Persian writers require to use Zero-Width-Non-Joiner. Both Arabic and Persian writers require the appropriate comma, semicolon, question mark, and a set of Hamza's (in the current set of Special characters, under the Arabic section, the 3rd to 8th items are required in Arabic, and 3rd, 4th, 5th, 6th and 8th characters are required for Persian). Also, Tanwins are required for Arabic (they are missing now) and one of the Tanwins is also used in Persian.

Finally, Arabic and Persian use different K's so we need to take care of that too.

Briefly, if you could direct me to where the current character set is stored, I could come up with a patch right away!
Comment 3 Huji 2010-07-02 14:42:59 UTC
Actually, I found it so I'm going to patch this.
Comment 4 Huji 2010-07-02 14:55:24 UTC
Fixed with r68880.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links