Last modified: 2010-03-12 22:35:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia migrated from Bugzilla to Phabricator. Bug reports are handled in Wikimedia Phabricator.
This static website is read-only and for historical purposes. It is not possible to log in and except for displaying bug reports and their history, links might be broken. See T4377, the corresponding Phabricator task for complete and up-to-date bug report information.
Bug 2377 - README, INSTALL, RELEASE-NOTES : AMP prerequisite information is inconsistent
README, INSTALL, RELEASE-NOTES : AMP prerequisite information is inconsistent
Product: MediaWiki
Classification: Unclassified
Documentation (Other open bugs)
All All
: Normal normal with 2 votes (vote)
: ---
Assigned To: Nobody - You can work on this!
Depends on: 1977
Blocks: documentation
  Show dependency treegraph
Reported: 2005-06-10 21:05 UTC by Zigger
Modified: 2010-03-12 22:35 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Description Zigger 2005-06-10 21:05:09 UTC
There are inconsistencies between README and INSTALL, and between 1.3/1.4/1.5,
for the AMP prerequisites.
Some are due to the REL1_4 change INSTALL. not being applied to HEAD.

1. Monobook problem

README 1.3.13 - no mention of the 1.3 monobook incompatibility with PHP 5
       1.4.5, 1.5alpha2 - mentions monobook problem in PHP section, which was
fixed in 1.4.x

2. Recommended PHP version in INSTALL - 3x "4.3.x" should be "4.3.2", 2x add "or
higher", 3x "preferred"->"recommended"

INSTALL: 1.3.13, 1.5alpha2 - "4.3.x is preferred"
         1.4.5 - "4.3.x or 5.0.x is preferred"
README:  1.3.13, 1.4.5, 1.5alpha2 - "4.3.2 or higher is recommended"

3. Recommended MySQL version - 3x use README wording in INSTALL

INSTALL 1.3.13, 1.4.5, 1.5alpha2 - "4.0.x is preferred"
README  "4.0 or later is strongly recommended"

4. MySQL 4.1 warnings

INSTALL 1.3.13, 1.5alpha2 - lack mention of MySQL 4.1
        1.4.5 - refers MySQL 4.1 users to RELEASE-NOTES

RELEASE-NOTES 1.3.13 - lacks mention of MySQL 4.1
              1.4.5 - deals with MySQL 4.1 authentication (bug 650), UTF8 key
(bug 1322) and backup issues
              1.5alpha2 - only mentions the UTF8 key problem specifically (in
the to-do list)

5. PHP runtime options

RELEASE-NOTES has a security note about register_globals, which would also be
appropriate in INSTALL.

INSTALL could also have specific warnings about well-known PHP runtime options
known to break MediaWiki functionality.  safe_mode is already mentioned in the
1.4.5 and 1.5alpha2 INSTALL, but the magic_quotes_* settings crop up from time
to time.  Some are checked & prevent installation, so it would be nice to give
Comment 1 Antoine "hashar" Musso (WMF) 2006-04-30 21:00:00 UTC
it is way better with 1.6 RELEASE-NOTES:

== Compatibility ==

Older PHP 4.2 and 4.1 releases are no longer supported; PHP 4 users must
upgrade to 4.3.3 or later.

MediaWiki 1.6 is the last major version to support PHP 4; future versions
will require PHP 5.

MySQL 3.23.x is no longer supported; some older hosts may need to upgrade.
At this time we still recommend 4.0, but 4.1/5.0 will work fine in most cases.

Note You need to log in before you can comment on or make changes to this bug.