Last modified: 2013-02-22 05:45:05 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23594 - Improve the error message presented when attempting to undelete a page for which the topmost revision is hidden
Improve the error message presented when attempting to undelete a page for wh...
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks: revdel messages
  Show dependency treegraph
 
Reported: 2010-05-19 10:36 UTC by FT2
Modified: 2013-02-22 05:45 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description FT2 2010-05-19 10:36:28 UTC
To reproduce:

1/ Create a page with one revision
2/ Delete the page using normal delete
3/ Apply RevDelete to hide the content of the deleted revision
4/ Try to undelete the page using normal delete.

The same can happen on pages with many revisions if selective undelete is used, when RevDelete happens to be applied to the latest revision to be selectively undeleted. (Eg in cases of vandalism or page move fixing)

Example, try undeleting the following:

http://en.wikipedia.org/w/index.php?title=Special:Undelete&target=User%3AFT2%2Ftest5

Error is correct but inelegant and inaccurate, suggesting something has not been caught or some text parameter is missing.
Comment 1 Bawolff (Brian Wolff) 2011-02-26 16:57:25 UTC
I can't reproduce. When doing your steps (on trunk) i get:

Undelete failed; someone else may have undeleted the page first.

Undeletion will not be performed if it will result in the top page or file revision being partially deleted. In such cases, you must uncheck or unhide the newest deleted revision. 


Can you confirm if the error is still present?
Comment 2 FT2 2011-03-01 18:26:51 UTC
Looks like this edge case has been caught since 2010 by some kind of extra test for the top page or file being deleted. It now acts as I'd expect, error if the text is hidden, allows it if the edit summary is hidden.

The error message has a slight bug, the presence of <p></p>:

"Undelete failed; someone else may have undeleted the page first."
"<p></p>"

The error message should also by default link to the delete log for the page - it's telling the user there is probably an issue related to delete/undelete. At present the error doesn't give any useful links the user can click.
Comment 3 Dan Collins 2011-07-09 01:13:31 UTC
This appears to be fixed except that the message isn't quite as useful as it could be, but there is no obvious bug or uncaught error. The error message could use a link to the appropriate delete log entry. However the message has been updated since FT2's comment, there is no longer an empty p tag. Marking the bug appropriately, as it is not a revision deletion error.
Comment 4 Bugmeister Bot 2011-08-19 19:12:20 UTC
Unassigning default assignments. http://article.gmane.org/gmane.science.linguistics.wikipedia.technical/54734
Comment 5 Sumana Harihareswara 2013-02-22 00:01:03 UTC
Still an issue?
Comment 6 Nemo 2013-02-22 05:45:05 UTC
https://test.wikipedia.org/wiki/Special:Undelete/Bug23594 :

Undelete failed:

Undeletion will not be performed if it will result in the top page or file revision being partially deleted.
In such cases, you must uncheck or unhide the newest deleted revision.
----
I call this fixed; adding log excerpts is a separate enhancement request.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links