Last modified: 2012-04-19 21:43:07 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23578 - Link dialog puts spaces inside links, causes markup like [[Foo ]]bar which renders as [[Foo bar|Foo]]
Link dialog puts spaces inside links, causes markup like [[Foo ]]bar which re...
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 24493 36111
  Show dependency treegraph
 
Reported: 2010-05-18 07:08 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-05-18_LinkCreate.pdf (76.73 KB, application/pdf)
2010-05-18 07:08 UTC, Calcey QA
Details

Description Calcey QA 2010-05-18 07:08:06 UTC
Created attachment 7379 [details]
Wiki_2010-05-18_LinkCreate.pdf

Reporting against Babaco Release : r66321
Tested link :http://prototype.wikimedia.org/en.wikipedia.org/Main_Page

Steps to Reproduce ::

1) Select a word from the text and highlight 
2) Click on link button from the tool bar
3) Click on insert 
4) Preview the changes.
<<the link is extended to the word next to the selected. This was not selected for the link initially.>>

Expected Outcome::
Only the text highlighted should contain the link.


Test Environment::
Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1.8) Gecko/20100202 Firefox/3.5.8

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3)

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Comment 1 Roan Kattouw 2010-05-18 21:20:32 UTC
Removing reference to "Search and Replace" from summary, I fail to see how S&R is related at all.

This is a very interesting mix between IE including the trailing space in the selection and [[Foo ]]bar being interpreted as [[Foo bar|Foo]] due to the link trail. The best fix is probably to make the link dialog smart so it inserts [[Foo]]<SPACE> when it really wants to insert [[Foo<SPACE>]]
Comment 2 Roan Kattouw 2010-06-07 15:52:33 UTC
Fixed in r67543.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links