Last modified: 2014-05-14 11:16:08 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 23028 - Upload form doesn't work with non-Latin filenames in IE
Upload form doesn't work with non-Latin filenames in IE
Status: RESOLVED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
SemanticForms (Other open bugs)
unspecified
All All
: Normal critical with 1 vote (vote)
: ---
Assigned To: Yaron Koren
: i18n
: 33233 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-02 14:57 UTC by yakoff
Modified: 2014-05-14 11:16 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description yakoff 2010-04-02 14:57:03 UTC
When uploading file with non-latin characters in its name (e.g. russian), the file is uploaded, but the filename substituted in the corresponding field of the main form gets corrupted (looks like broken utf).

This is true for MSIE, while in Chrome everything works fine.

Tested it both on my own installation and on http://discoursedb.org/wiki/Form:Images_test
Comment 1 Chad H. 2010-04-02 14:58:46 UTC

*** This bug has been marked as a duplicate of bug 1780 ***
Comment 2 yakoff 2010-04-02 15:09:35 UTC
I don't think it is a duplicate of bug 1780..

The problem affects the Special:UploadWindow and the way it returns the filename to the form. When Special:UploadWindow closes and passes the filename to the main form the string gets corrupted and instead of "Файл.jpg" it appears as "Файл.jpg"

But the uploading itself is fine. File is uploaded and can be found with correct name.
Comment 3 Yaron Koren 2011-09-07 19:43:06 UTC
Renamed to "Upload form doesn't work with non-Latin filenames *in IE*"
Comment 4 Niklas Laxström 2012-08-19 09:05:31 UTC
Bug 33233 is almost the same but it is not confined to IE only.
Comment 5 Niklas Laxström 2012-08-23 16:25:17 UTC
*** Bug 33233 has been marked as a duplicate of this bug. ***
Comment 6 Andre Klapper 2012-11-06 18:01:29 UTC
yakoff: Is this still a problem? If so, with which IE version?
Comment 7 TeleComNasSprVen 2014-05-14 11:15:59 UTC
No response from filer, and uploading with Cyrillic characters works for me in Internet Explorer 11.0.7. Therefore closing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links