Last modified: 2013-09-04 12:26:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22992 - Merging fails, resulting in revert of previous change
Merging fails, resulting in revert of previous change
Status: RESOLVED DUPLICATE of bug 11922
Product: MediaWiki
Classification: Unclassified
Page editing (Other open bugs)
unspecified
PC Linux
: Low critical (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-29 11:23 UTC by Arne Nordmann
Modified: 2013-09-04 12:26 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Arne Nordmann 2010-03-29 11:23:17 UTC
Hi.
I stumbled upon a serious issue with having an edit conflict. Result of this edit conflict was me reverting the previous edit by another athor.[1]

The edit I did was just adding a single character (a '-' between 'STOL' and 'Flugzeug' in the first sentence). In the meantime, bevor i saved my edit, another user did a more complex edit, but including the character that i was about to add.[2]

As far as i realize when I saved my edit, the software recognizes that both edits can be merged. I didn't get any hint that there was an edit conflict, but my edit was just saved. Result was that just my character change was saved, reverting all of the other changed that were made by the previous edit.

[1] http://de.wikipedia.org/w/index.php?title=AVCEN_Jetpod&diff=prev&oldid=72484506
[2] http://de.wikipedia.org/w/index.php?title=AVCEN_Jetpod&diff=prev&oldid=72445940
Comment 1 Priyanka Dhanda 2010-03-30 17:34:33 UTC
I am still trying to reproduce this on my local install. Let me try switching the same version as de.wikipedia.org.
Comment 2 Platonides 2010-03-30 18:06:11 UTC
diff3 correctly handles the conflict and the code path must have detected the different submisison.
When did you click 'edit'? Did you wait 21h 48' from starting edit to submitting?
Comment 3 Arne Nordmann 2010-03-31 06:58:00 UTC
It's hard to tell how long I waited between entering the form und submitting, but most certainly not more than 10 to 15 minutes.
Comment 4 Arne Nordmann 2010-03-31 07:04:42 UTC
As mentioned by another user I not only reverted the mentioned edit by User:Hydro but also the previous edit.
It is as I would have edited the older version 72040588.[1]
But in that case I would have gotten a notice, that I am editing an older page, right?!

[1] http://de.wikipedia.org/w/index.php?title=AVCEN_Jetpod&oldid=72040588
Comment 5 Platonides 2010-03-31 13:10:24 UTC
(In reply to comment #4)
> As mentioned by another user I not only reverted the mentioned edit by
> User:Hydro but also the previous edit.
> It is as I would have edited the older version 72040588.[1]
> But in that case I would have gotten a notice, that I am editing an older page,
> right?!

Right.


(In reply to comment #3)
> It's hard to tell how long I waited between entering the form und submitting,
> but most certainly not more than 10 to 15 minutes.

Look at the times, Hydro edited at 11:41, 28. Mär. 2010  and your edit was at 09:29, 29. Mär. 2010. So you were editing a text many hours old (from 14:49, 18. Mär. 2010 if also taking Waerfelu edit into acount).
Saving checks the version against the current one at the master, so this couldn't happen.
I suspect that flagged revs may have interferred, but all edits were autosighted, making it mroe unlikely. :/
Comment 6 Nemo 2013-03-06 12:32:19 UTC
How does this differ from bug 11922?
Comment 7 Andre Klapper 2013-09-04 12:21:33 UTC
Indeed looks like a dup of bug 11922. Thanks Nemo!

*** This bug has been marked as a duplicate of bug 11922 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links