Last modified: 2012-05-15 14:21:19 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22865 - Lists format incorrectly when next to a "left" floated image
Lists format incorrectly when next to a "left" floated image
Status: RESOLVED DUPLICATE of bug 7353
Product: MediaWiki
Classification: Unclassified
General/Unknown (Other open bugs)
1.15.x
PC Windows Server 2003
: Normal trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/wiki/User:Obl...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-17 17:03 UTC by Ted Osborne
Modified: 2012-05-15 14:21 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Ted Osborne 2010-03-17 17:03:48 UTC
When a bulleted or numbered list (nested or otherwise) appears to the right of a "float left" image ("[[file:foo.jpg|left...]]"), the bullet symbols do not format correctly.

Here's a wikitext test case (see <http://en.wikipedia.org/wiki/User:Obliquemotion/list_layout>):

====================================================================
[[File:Quartz, Tibet.jpg|thumbnail|368px|left]]
Here is a list of things:

* Archery
*# Bow
*# Arrow
*# Target
* Boating
* Curling

Are the bullet symbols to left of the rest of the text's left margin? They shouldn't be. It only happens when something floats to the left of the list (like an image or a float:left div). Also, notice the indentation of the first line of text (preceding the list).
{{clear}}
Here is the same list of things, but with nothing floating to its left:

* Archery
*# Bow
*# Arrow
*# Target
* Boating
* Curling

Are the bullets (incorrectly) left of the main text?
====================================================================

Firefox 3.5.8 displays it incorrectly, and IE 8 is worse (symbols are clipped by the image)
Comment 1 Ted Osborne 2010-03-17 17:05:47 UTC
Added test case URL.
Comment 2 Derk-Jan Hartman 2010-03-17 20:36:01 UTC
This is normal HTML/CSS behavior. As far as I'm concerned, this was one of the worst decisions ever made in CSS. The fix is to add (for vector):

#content ul, ol {
  list-style-position: inside;
}

But I'm not sure what kind of effect that might have on our existing content, nor do I know how well it is supported in browsers. Perhaps it's time to find out however. I'm rather sure there was an existing bugreport for this, but I cannot find it at this time....
Comment 3 Derk-Jan Hartman 2010-03-17 20:43:58 UTC

*** This bug has been marked as a duplicate of bug 7353 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links