Last modified: 2012-09-27 01:10:52 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22858 - IE6 throws JS error about csshover.htc when loading enhanced toolbar
IE6 throws JS error about csshover.htc when loading enhanced toolbar
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
1.17.x
All All
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-17 08:21 UTC by Calcey QA
Modified: 2012-09-27 01:10 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-17_IE6_toolbar.pdf (77.84 KB, application/pdf)
2010-03-17 08:21 UTC, Calcey QA
Details
Wiki_2010-03-18_IE6.pdf (81.33 KB, application/pdf)
2010-03-18 09:37 UTC, Calcey QA
Details

Description Calcey QA 2010-03-17 08:21:01 UTC
Created attachment 7209 [details]
Wiki_2010-03-17_IE6_toolbar.pdf

Reporting against Babaco Release : r63174
Tested link :http://prototype.wikimedia.org/deployment-en/


Steps to Reproduce ::

Please refer the attachment

Test Environment::

Mozilla/4.0 (compatible;MSIE 6.0;Windows NT 5.1;SV1;.NET CLR 2.0.50727)
Comment 1 Trevor Parscal 2010-03-17 17:37:28 UTC
Solved in r63866 by checking if the toolbar is supported before removing the
old one.
Comment 2 Calcey QA 2010-03-18 09:37:38 UTC
Created attachment 7218 [details]
Wiki_2010-03-18_IE6.pdf

Verified on Babaco Release : r59858
Tested link :http://en.wikipedia.org

IE 6 not display the tool bar. This time IE 6 gives an error too.
Comment 3 Calcey QA 2010-03-18 09:38:27 UTC
(In reply to comment #2)
> Created an attachment (id=7218) [details]
> Wiki_2010-03-18_IE6.pdf
> 
> Verified on Babaco Release : r59858
> Tested link :http://en.wikipedia.org
> 
> IE 6 not display the tool bar. This time IE 6 gives an error too.

Therefore re-opening the bug
Comment 4 Roan Kattouw 2010-03-18 11:41:11 UTC
Error message from the attachment:

Access is denied to: http://bits.wikimedia.org/skins-1.5/vector/csshover.htc

Seems this is a bug in Vector's :hover-for-IE patch then.
Comment 5 Trevor Parscal 2010-03-19 17:47:02 UTC
No, this is because bits.wikimedia.org is not en.wikipedia.org or whatever the project's URL is. We need to not server this file from bits.wikimedia.org but rather go back to serving it from the project domain as it was when I designed this skin. This is why our localhost installs don't throw this error.
Comment 6 Roan Kattouw 2010-03-22 20:25:36 UTC
(In reply to comment #5)
> No, this is because bits.wikimedia.org is not en.wikipedia.org or whatever the
> project's URL is. We need to not server this file from bits.wikimedia.org but
> rather go back to serving it from the project domain as it was when I designed
> this skin. This is why our localhost installs don't throw this error.
Sounds like a relatively easy fix, considering that the file is still being served at the old en.wikipedia.org URL. Probably does need addition of an extra $wgStylePath-like var though.
Comment 7 Trevor Parscal 2010-04-26 21:05:42 UTC
Resolved in r65555 by adding $wgLocalStylePath, which shall not be changed to point to a domain different from the site, ever! Now Vector uses this when including the csshover.htc file.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links