Last modified: 2012-04-19 21:43:17 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22841 - Dialogs: Insert Tables : Opera is not creating the table header even the option is selected
Dialogs: Insert Tables : Opera is not creating the table header even the opti...
Status: CLOSED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Adam Miller
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-03-15 10:02 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_2010-03-15_Opera_Table.pdf (98.83 KB, application/pdf)
2010-03-15 10:02 UTC, Calcey QA
Details
Wiki_2010-03-17_Opera_Table.pdf (19.37 KB, application/pdf)
2010-03-17 10:10 UTC, Calcey QA
Details

Description Calcey QA 2010-03-15 10:02:08 UTC
Created attachment 7201 [details]
Wiki_2010-03-15_Opera_Table.pdf

Reporting against Babaco Release :  r63174
Tested link :http://prototype.wikimedia.org/deployment-en/

Steps to Reproduce ::

1) Create a table with heading
<<Header section not created>>

Expected Outcome::
Header section should created when the option selected


Test Environment::
Opera/9.80 (Windows NT 6.1; U; en) Presto/2.2.15 Version/10.00

Opera/9.80 (X11; Linux i686; U; en) Presto/2.2.15 Version/10.00

Opera/9.80 (Macintosh; Intel Mac OS X; U; en) Presto/2.2.15 Version/10.10
Comment 1 Roan Kattouw 2010-03-15 15:41:10 UTC
1) Are you sure this only happens in Opera and not in other browsers?
2) If so, could you verify whether Opera "eats" the top row consistently, i.e. creates 3 rows when asked for 4?
Comment 2 Roan Kattouw 2010-03-15 16:13:48 UTC
Thanks to Adam's immediate assistance, I was able to track this down to a bug in Opera breaking the specific way we checked for a checkbox's status. Using a slightly different but equivalent way of detecting this does work.

Fixed in r63773.
Comment 3 Calcey QA 2010-03-16 06:07:04 UTC
The bug still re-producible. Therefore re-open the bug
Comment 4 Adam Miller 2010-03-16 16:08:08 UTC
Just removed one small bit of code that was causing this bug to continue to occur. 

Fixed in r63819.
Comment 5 Calcey QA 2010-03-17 10:10:42 UTC
Created attachment 7212 [details]
Wiki_2010-03-17_Opera_Table.pdf

Is this the expected behavior?
Comment 6 Roan Kattouw 2010-03-17 10:53:21 UTC
(In reply to comment #5)
> Created an attachment (id=7212) [details]
> Wiki_2010-03-17_Opera_Table.pdf
> 
> Is this the expected behavior?

No. Which wiki did you observe this on? Based on the example texts it seems to be using a very old version of the software.
Comment 7 Calcey QA 2010-03-17 10:57:18 UTC
Reporting against Babaco Release : r63174
Tested link :http://prototype.wikimedia.org/deployment-en/

Environments:


Opera/9.63 (Windows NT 6.1; U; en) Presto/2.1.1

Opera/9.80 (Windows NT 6.1; U; en) Presto/2.2.15 Version/10.00

Opera/9.80 (Macintosh; Intel Mac OS X; U; en) Presto/2.2.15 Version/10.10

No pop-up window shows for the table link click.
Comment 8 Calcey QA 2010-03-17 12:43:32 UTC
as per comment 6, re-opening the bug
Comment 9 Adam Miller 2010-03-17 15:23:45 UTC
I can't find a build of Opera with version number 9.8 available online, but was unable to replicate this in 10.x or 9.6 on Mac and Windows. As per comment 6, it also appears the attached screen shot is of a very old build of our software. Notice the differences in the font of editor text and the differences between icons.
Comment 10 Calcey QA 2010-05-19 05:54:01 UTC
Reporting against Babaco Release : r66628 
Tested link :http://prototype.wikimedia.org/en.wikipedia.org/Main_Page

Status : verified bug is not reproducible and closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links