Last modified: 2013-04-22 16:15:18 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22457 - Explain better the meaning of "By e-mail" button
Explain better the meaning of "By e-mail" button
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Interface (Other open bugs)
unspecified
All All
: Low trivial (vote)
: ---
Assigned To: Liangent
:
Depends on:
Blocks: messages
  Show dependency treegraph
 
Reported: 2010-02-10 08:35 UTC by Nemo
Modified: 2013-04-22 16:15 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
description patch (2.90 KB, patch)
2011-12-14 09:20 UTC, Emily B
Details

Description Nemo 2010-02-10 08:35:06 UTC
As suggested by Siebrand on [[betawiki:Thread:Support/MediaWiki:Createaccountmail/en]], I suggest to add a brief explanation of the meaning of the "By e-mail" button on [[Special:Userlogin]] (new account creation), otherwise this form can be quite confusing and produce unexpected results: http://www.mediawiki.org/w/index.php?title=Manual%3APreventing_access&action=historysubmit&diff=297239&oldid=287376 .
Comment 1 Emily B 2011-12-14 09:20:17 UTC
Created attachment 9688 [details]
description patch

this is the patch I created to solve this problem, let me know what you think
Comment 2 Liangent 2011-12-14 14:29:52 UTC
I guess it could be better to replace the button with a checkbox, and place the checkbox above the password fields, then hide the password fields if the checkbox is checked...
Comment 3 Liangent 2011-12-14 14:32:25 UTC
(In reply to comment #1)
> Created attachment 9688 [details]
> description patch
> 
> this is the patch I created to solve this problem, let me know what you think

This patch inserts 'byemail-explanation' inside 'yourname' in MessagesQqq.php.
Comment 4 Sumana Harihareswara 2011-12-14 16:46:33 UTC
Added the need-review keyword to indicate that this patch awaits review from a developer.  Thanks, Emily!
Comment 5 Liangent 2011-12-14 16:56:04 UTC
(In reply to comment #4)
> Added the need-review keyword to indicate that this patch awaits review from a
> developer.  Thanks, Emily!

This patch is buggy as I said above. Should I remove "need-review"?
Comment 6 Sumana Harihareswara 2011-12-14 16:58:50 UTC
Liangent, I hadn't realized that your "I guess it could be better to..." and "this patch inserts..." comments were critique indicating that the patch has a problem that needs fixing.  I believe this is Emily's first patch to MediaWiki; could you be more specific to help her see how the fix ought to be done instead?

I've replaced "need-review" with the "reviewed" keyword.
Comment 7 Liangent 2011-12-14 17:10:32 UTC
(In reply to comment #6)
> Liangent, I hadn't realized that your "I guess it could be better to..." and
> "this patch inserts..." comments were critique indicating that the patch has a
> problem that needs fixing.  I believe this is Emily's first patch to MediaWiki;
> could you be more specific to help her see how the fix ought to be done
> instead?
> 
> I've replaced "need-review" with the "reviewed" keyword.

"This patch is buggy as I said above. Should I remove "need-review"?" is the problem, though I didn't have a complete look at it.

To Emily:

You inserted "'byemail-explanation',       => 'Explains that clicking By E-mail sends a random password to the account that can be changed on login. In [[Special:UserLogin]]'" as a string into the content of 'yourname' message, instead of a new message 'byemail-explanation' with its content 'Explains that clicking By E-mail sends a random password to the account that can be changed on login. In [[Special:UserLogin]]'.

To Sumana:

Actually I believe Emily can spot this little mistake if he/she has a look at the patch again.
Comment 8 Emily B 2011-12-15 01:58:32 UTC
thanks for the feedback, I'll work at improving my patch as soon as I can. Unfortonately this is finals week for me at school so I might not be able to get to it right away. Thanks :)
Emily
Comment 9 Sumana Harihareswara 2012-01-10 00:42:08 UTC
Emily, have you had time to revise the patch?  I hope you get a chance soon.  Thanks!
Comment 10 Emily B 2012-01-10 08:51:39 UTC
@Sumana, sorry for the delay, I'm getting to it now. 
@Liangent do you mean i should just add something like

#By-email explanation
'byemail-explanation'        => 'Clicking By E-mail will send an an auto-generated password to the provided email that can be reset after that new user logs in',


in the file either before of after user login messages?

Is the issue where the message is placed in the file?
Comment 11 Liangent 2012-01-10 08:56:30 UTC
(In reply to comment #10)
> @Sumana, sorry for the delay, I'm getting to it now. 
> @Liangent do you mean i should just add something like
> 
> #By-email explanation
> 'byemail-explanation'        => 'Clicking By E-mail will send an an
> auto-generated password to the provided email that can be reset after that new
> user logs in',
> 
> 
> in the file either before of after user login messages?
> 
> Is the issue where the message is placed in the file?

In MessageQqq.php you code looks like:

'yourname'                   => "In user preferences,
'byemail-explanation',       => 'Explains that clicking By E-mail sends a random password to the account that can be changed on login. In [[Special:UserLogin]]'

<nowiki>{{</nowiki>[[Gender|GENDER]]<nowiki>}}</nowiki> is '''NOT''' supported.

{{Identical|Username}}",

But obviously it should be:

'yourname'                   => "In user preferences,

<nowiki>{{</nowiki>[[Gender|GENDER]]<nowiki>}}</nowiki> is '''NOT''' supported.

{{Identical|Username}}",
'byemail-explanation',       => 'Explains that clicking By E-mail sends a random password to the account that can be changed on login. In [[Special:UserLogin]]',

- or -

'byemail-explanation',       => 'Explains that clicking By E-mail sends a random password to the account that can be changed on login. In [[Special:UserLogin]]',
'yourname'                   => "In user preferences,

<nowiki>{{</nowiki>[[Gender|GENDER]]<nowiki>}}</nowiki> is '''NOT''' supported.

{{Identical|Username}}",
Comment 12 Liangent 2012-01-10 08:57:18 UTC
Sorry. should be

'yourname'                   => "In user preferences,

<nowiki>{{</nowiki>[[Gender|GENDER]]<nowiki>}}</nowiki> is '''NOT''' supported.

{{Identical|Username}}",
'byemail-explanation'        => 'Explains that clicking By E-mail sends a
random password to the account that can be changed on login. In
[[Special:UserLogin]]',

- or -

'byemail-explanation'        => 'Explains that clicking By E-mail sends a
random password to the account that can be changed on login. In
[[Special:UserLogin]]',
'yourname'                   => "In user preferences,

<nowiki>{{</nowiki>[[Gender|GENDER]]<nowiki>}}</nowiki> is '''NOT''' supported.

{{Identical|Username}}",
Comment 13 Liangent 2012-12-16 11:27:50 UTC
(In reply to comment #2)
> I guess it could be better to replace the button with a checkbox, and place
> the
> checkbox above the password fields, then hide the password fields if the
> checkbox is checked...

Done with this solution in I7bf57eef64fea19a8237f997019e0b2bfdf401b3
Comment 14 Alex Monk 2013-01-28 17:23:58 UTC
(In reply to comment #13)
> (In reply to comment #2)
> > I guess it could be better to replace the button with a checkbox, and place
> > the
> > checkbox above the password fields, then hide the password fields if the
> > checkbox is checked...
> 
> Done with this solution in I7bf57eef64fea19a8237f997019e0b2bfdf401b3

Merged by Siebrand on the 24th. Is this better now?
Comment 15 Nemo 2013-01-28 17:57:06 UTC
Yes, this is fixed, or rather way more than asked has been done. I've not tested (and the commit says nothing about):
1) wikis with min password length 0;
2) wikis where not all logged in users can create an account.
Moreover I suppose that unregistered users can no longer create accounts for others by email? But I'm not sure this can be called a regression.
Comment 16 Liangent 2013-01-29 01:23:24 UTC
(In reply to comment #15)
> Yes, this is fixed, or rather way more than asked has been done. I've not
> tested (and the commit says nothing about):
> 1) wikis with min password length 0;
> 2) wikis where not all logged in users can create an account.
> Moreover I suppose that unregistered users can no longer create accounts for
> others by email? But I'm not sure this can be called a regression.

Createaccountemail was disabled for anons in the past too.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links