Last modified: 2012-04-19 21:43:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22440 - Cursor position randomly jumps
Cursor position randomly jumps
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal major (vote)
: ---
Assigned To: Nimish Gautam
en.wikipedia.org and all other wikime...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-08 23:22 UTC by Nimish Gautam
Modified: 2012-04-19 21:43 UTC (History)
8 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Nimish Gautam 2010-02-08 23:22:33 UTC
While typing, the cursor will jump back some number (usually about 3 to 5) of spots in the text.

This has been, so far, incredibly difficult to reproduce, but has been seen in FF 3.6 for Linux and Mac.

Sometimes it will wait until the user is done typing (indicating possible link to the delayedBind) but other times it will shift *as* the user is typing.
Comment 1 Roan Kattouw 2010-02-09 00:30:34 UTC
Guillaume's reproducing instructions included pressing Enter at the end of a header line and seeing two blank lines being created. This is also not consistently reproducible, and seems to be linked to the cursor moving issue.
Comment 2 Calcey QA 2010-02-09 11:38:08 UTC
Was not able to reproduce the defect in all browsers
Comment 3 Calcey QA 2010-02-10 11:29:09 UTC
Test link : http://prototype.wikimedia.org/deployment-en/
Version : r62215

Tried the scenario on Fire Fox 3.6 on Mac. Was not able to reproduce the same.
Comment 4 Tisza Gergő 2010-02-12 00:41:38 UTC
I got this when adding section titles: after typing "== foo ==" (or just "== foo =") and pausing for a moment, the cursor jumped to the middle of the opening == just as the toc changed. This happened every time when I added a section title, but I couldn't get it again after a reload. This was the edit in question: http://hu.wikipedia.org/w/index.php?title=MediaWiki:Common.js&diff=prev&oldid=7190938
Comment 5 Tisza Gergő 2010-02-12 00:42:11 UTC
(forgot to mention it was FF 3.5/WinXP.)
Comment 6 Calcey QA 2010-02-16 07:08:49 UTC
Tested link: http://prototype.wikimedia.org/deployment-en/
Version : r62529

Not able to re-produce the bug stated with the given steps. May be because of the bug 22543
Comment 7 Nimish Gautam 2010-02-18 00:23:26 UTC
fixed with adding <p> classes as TOC markers rather than invisible <divs>

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links