Last modified: 2012-04-19 21:43:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22401 - Line breaks are removed when previewed or saved
Line breaks are removed when previewed or saved
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: High critical (vote)
: ---
Assigned To: Trevor Parscal
Production
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-05 23:59 UTC by nkomura@wikimedia.org
Modified: 2012-04-19 21:43 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_bug_2010-02-09_22401.pdf (37.33 KB, application/pdf)
2010-02-09 07:53 UTC, Calcey QA
Details
Wiki_bug_2010-02-09_22401_II.pdf (62.78 KB, application/pdf)
2010-02-09 08:55 UTC, Calcey QA
Details
Wiki_bug_2010-02-09_22401_III.pdf (192.07 KB, application/pdf)
2010-02-10 09:16 UTC, Calcey QA
Details

Description nkomura@wikimedia.org 2010-02-05 23:59:31 UTC
Line breaks are ignored when previewed or saved.  The problem was reported in the code commit note.  

http://www.mediawiki.org/wiki/Special:Code/MediaWiki/61991

The problem was reproduced in FF3 on Ubuntu and FF3.5 on Windows 7.
Comment 1 nkomura@wikimedia.org 2010-02-06 00:11:26 UTC
With Opera 10 and IE8 on Windows 7, single line break is ignored.  But the double breaks renders as a single break.
Comment 2 Roan Kattouw 2010-02-08 16:42:16 UTC
I don't see how r61991 is directly related; maybe stripping the <br> at the end of a <p> should be Firefox-specific as well.

Also, could you tell us whether the line breaks in question were added line breaks or line breaks already present in the article?
Comment 3 nkomura@wikimedia.org 2010-02-08 22:43:33 UTC
For my test cases, added line breaks disappear when the edits are previewed or saved.  Existing line breaks are fine.  (FF3 Ubuntu 9.04)
Comment 4 Trevor Parscal 2010-02-08 23:33:08 UTC
This was already resolved in http://www.mediawiki.org/wiki/Special:Code/MediaWiki/62041 but due to some infrastructure issues not pushed out to non-European visitors.
Comment 5 Calcey QA 2010-02-09 07:53:11 UTC
Created attachment 7089 [details]
Wiki_bug_2010-02-09_22401.pdf

Tested link : http://prototype.wikimedia.org/deployment-en/

On following browsers the functionality fails.Check attachment for Firefox related issue

IE7
FireFox 3.6 
FireFox 3.5
FireFox 3.0
Safari 4
Chrome 4
IE8
Opera 10

Opera 9.6 function right
Comment 6 Calcey QA 2010-02-09 07:55:02 UTC
(In reply to comment #5)
> Created an attachment (id=7089) [details]
> Wiki_bug_2010-02-09_22401.pdf
> 
> Tested link : http://prototype.wikimedia.org/deployment-en/
> 
> On following browsers the functionality fails.Check attachment for Firefox
> related issue
> 
> IE7
> FireFox 3.6 
> FireFox 3.5
> FireFox 3.0
> Safari 4
> Chrome 4
> IE8
> Opera 10
> 
> Opera 9.6 function right

Therefore reopening the bug
Comment 7 nkomura@wikimedia.org 2010-02-09 07:59:41 UTC
I should have mentioned that single line break is ignored.  Please verify double line breaks inserts a line break in preview or save.
Comment 8 Calcey QA 2010-02-09 08:55:28 UTC
Created attachment 7091 [details]
Wiki_bug_2010-02-09_22401_II.pdf

No double line inserts but <pre>...</pre> tag get inserted. Working fine for Opera 9.6  and IE 7 browsers
Comment 9 Roan Kattouw 2010-02-09 13:41:56 UTC
(In reply to comment #8)
> Created an attachment (id=7091) [details]
> Wiki_bug_2010-02-09_22401_II.pdf
> 
> No double line inserts but <pre>...</pre> tag get inserted. Working fine for
> Opera 9.6  and IE 7 browsers

The pre tags get inserted because of leading spaces on lines.
Comment 10 Calcey QA 2010-02-10 06:08:26 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > Created an attachment (id=7091) [details] [details]
> > Wiki_bug_2010-02-09_22401_II.pdf
> > 
> > No double line inserts but <pre>...</pre> tag get inserted. Working fine for
> > Opera 9.6  and IE 7 browsers
> 
> The pre tags get inserted because of leading spaces on lines.


Does different browsers read the leading spaces and line differently? Shouldn't all the browsers should function the same way? The attachment shows how different browses act.
Comment 11 Calcey QA 2010-02-10 09:16:54 UTC
Created attachment 7095 [details]
Wiki_bug_2010-02-09_22401_III.pdf


Please refer the attachment. Different browsers act different on data preview. When data copy and paste from a word document, Fire Fox add a tag in the editor. This is not shown in any other browser. But when a text copy and past from the wikimedia itself, that tag is not shown in Fire Fox
Comment 12 Calcey QA 2010-02-10 09:18:42 UTC
(In reply to comment #11)
> Created an attachment (id=7095) [details]
> Wiki_bug_2010-02-09_22401_III.pdf
> 
> 
> Please refer the attachment. Different browsers act different on data preview.
> When data copy and paste from a word document, Fire Fox add a tag in the
> editor. This is not shown in any other browser. But when a text copy and past
> from the wikimedia itself, that tag is not shown in Fire Fox

Test Environment : http://prototype.wikimedia.org/deployment-en/
Version :r62215
Comment 13 Trevor Parscal 2010-02-10 19:35:47 UTC
Resolved in r62258 - when new lines were created while the cursor was at a <br> within the body (on a blank line) the browser would not create <p> encapsulated new lines, but instead use raw text nodes in the body and more <br> tags (the browser just follows whatever is around the cursor) or in even more frustrating cases <div> tags which are not being handled for newline conversion at all. By wrapping <br> tags with <p> tags we ensure the browser always has the right hint, and the browser now properly encloses new lines, no matter where they were created at, with <p> tags.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links