Last modified: 2012-04-19 21:43:28 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22398 - Pasted text has line breaks
Pasted text has line breaks
Status: RESOLVED DUPLICATE of bug 22428
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All Linux
: High critical with 1 vote (vote)
: ---
Assigned To: Trevor Parscal
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2010-02-05 22:27 UTC by nkomura@wikimedia.org
Modified: 2012-04-19 21:43 UTC (History)
9 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
linebreaks are inserted when a block of text is pasted. (58.94 KB, image/png)
2010-02-05 22:27 UTC, nkomura@wikimedia.org
Details
Wiki_bug_2010-02-12_22398.pdf (89.09 KB, application/pdf)
2010-02-12 05:50 UTC, Calcey QA
Details
Wiki_bug_2010-02-16_22398.pdf (79.39 KB, application/pdf)
2010-02-16 06:12 UTC, Calcey QA
Details

Description nkomura@wikimedia.org 2010-02-05 22:27:34 UTC
Created attachment 7078 [details]
linebreaks are inserted when a block of text is pasted. 

When a block of text is copy/cut and pasted in the text editor, line breaks are inserted.  Please see the attachment.  

This problem was observed with FF3.0 on Ubuntu 9.04, FF3.5.5 on Windows 7.  Opera10 on Windows 7 did not exhibit this problem.
Comment 1 nkomura@wikimedia.org 2010-02-05 22:32:47 UTC
Adjusting importance to high/major
Comment 2 Nimish Gautam 2010-02-05 23:46:05 UTC
Extra linebreaks also appear when copying/pasting (1 linebreak becomes two)
Comment 3 nkomura@wikimedia.org 2010-02-08 17:42:28 UTC
Trevor says that the fix was applied on February 5th, but the problem still exists with FF3 on Ubuntu 9.04.
Comment 4 Calcey QA 2010-02-09 07:49:59 UTC
Tested link : http://prototype.wikimedia.org/deployment-en/

On following browsers the functionality fails

FireFox 3.6
FireFox 3.5
FireFox 3.0
Safari 4

At the time of text paste it shows the defined error but after click on preview the text align as normal
Chrome 4
IE8
Opera 10

IE7 and Opera 9.6 function normally
Comment 5 Guillaume Paumier 2010-02-09 17:54:55 UTC
(In reply to comment #2)
> Extra linebreaks also appear when copying/pasting (1 linebreak becomes two)

FYI this also happens when copying text from the edit window and pasting it in an external text editor
Comment 6 nkomura@wikimedia.org 2010-02-09 23:43:33 UTC
This bug may be related to https://bugzilla.wikimedia.org/show_bug.cgi?id=22428.
Comment 7 Calcey QA 2010-02-10 09:10:29 UTC
Tested link : http://prototype.wikimedia.org/deployment-en/
Version : r62215

When text copy/paste from a word document to editor, following browsers show extra line break.

Windows Env
Fire Fox 3.0 / 3.5 / 3.6
Chrome 4
Safari 4
Opera 10 

Fedora Env
Fire Fox 3.0

Note: Did not used an external editor.
Comment 8 Calcey QA 2010-02-12 05:50:20 UTC
Created attachment 7109 [details]
Wiki_bug_2010-02-12_22398.pdf

Tested link : http://prototype.wikimedia.org/deployment-en/
Version : r62243

Please refer the attachment for screen prints.

Following behaviors noted

FireFox 3.6 - additional line break added

Chrome 4/ Safari 4 - all the line breaks are removed
Comment 9 Trevor Parscal 2010-02-12 17:41:56 UTC
This has been fixed in revisions r62329 and r62334 but not yet deployed.
Comment 10 Calcey QA 2010-02-16 05:24:50 UTC
Tested link: http://prototype.wikimedia.org/deployment-en/
Version : r62529

Bug still can be reproduce and the output is same as the attachment (id=7109).
Comment 11 Calcey QA 2010-02-16 06:10:40 UTC
(In reply to comment #10)
> Tested link: http://prototype.wikimedia.org/deployment-en/
> Version : r62529
> 
> Bug still can be reproduce and the output is same as the attachment (id=7109) [details].

Re-loaded all the browsers with Shift + Refresh. 

FireFox versions add additional HTML tag before the pasted text.

Opera 9.6 / Chrome 4 and Safari 4 behave the same way as given in the document. Other browsers display the copy and pasted text normal. 


Therefore conclude as bug is not fixed.
Comment 12 Calcey QA 2010-02-16 06:12:13 UTC
Created attachment 7130 [details]
Wiki_bug_2010-02-16_22398.pdf

Screen prints
Comment 13 Calcey QA 2010-02-16 06:24:34 UTC
(In reply to comment #12)
> Created an attachment (id=7130) [details]
> Wiki_bug_2010-02-16_22398.pdf
> 
> Screen prints

The screen prints are for the scenario when text pasted from a word document.

Scenario 02 : Copy text from wiki document and past in another wiki editor : 
Safari 4/ Chrome 4 delete all the line breaks

Scenario 03 :Edit a wiki document, copy the content and paste in another wiki editor 
Opera 9.6 add an additional line break, Safari 4/ Chrome 4 delete all the line breaks and in other browsers it shows normal.
Therefore conclude as bug is not fixed.
Comment 14 nkomura@wikimedia.org 2010-02-16 16:56:01 UTC
reopening based on the test results.
Comment 15 Trevor Parscal 2010-02-16 21:27:39 UTC
Part of this bug is actually a duplicate of...

Bug 22428 - "Line breaks in pasted text not picked up in Safari 4, Chrome 4"

And the other part of this bug (copying text from the wikiEditor to an external editor) is a much different bug than this started out as or is titled with. Marking this as duplicated and adding new bug...

Bug 22554 - "Text copied from wikiEditor and pasted in external editor has extra blank lines"
Comment 16 Trevor Parscal 2010-02-16 21:28:13 UTC

*** This bug has been marked as a duplicate of bug 22428 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links