Last modified: 2012-04-19 21:43:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 22281 - Toolbar : Bullet create in different browsers are not the same
Toolbar : Bullet create in different browsers are not the same
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: High major (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 24493 36111
  Show dependency treegraph
 
Reported: 2010-01-27 07:09 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Wiki_r61537_2010-01-27_Bullet.pdf (244.42 KB, application/pdf)
2010-01-27 07:09 UTC, Calcey QA
Details

Description Calcey QA 2010-01-27 07:09:45 UTC
Created attachment 7027 [details]
Wiki_r61537_2010-01-27_Bullet.pdf

Reporting against Babaco Release : r61537

Steps to Reproduce ::

Please refer the attachment for more details. IE8 error is related to the bug id 22260


Expected Outcome::
All browsers should function the same.

Test Environment::
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)

Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30618)

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.04506.648; .NET CLR 3.5.21022)

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.28 (KHTML, like Gecko) Version/3.2.2 Safari/525.28.1

Opera/9.63 (Windows NT 6.0; U; en) Presto/2.1.1
Comment 1 Roan Kattouw 2010-01-27 15:21:27 UTC
The Opera and Safari behavior is correct.

Even after fixing bug 22260, Firefox was inserting "* Bulleted list item*Bulleted list item" without breaking the line, fixed that in r61577.

I couldn't reproduce the described IE7 behavior, it might have been fixed earlier. IE8 works fine now that bug 22260 is fixed.

Didn't test Chrome, could you test it again?
Comment 2 Naoko Komura 2010-01-27 17:20:37 UTC
changing the importance to High
Comment 3 Calcey QA 2010-02-01 05:04:30 UTC
Chrome behave the same way as shown in the attachment [1st screen print]. From the first bullet it add the second in the second row.

IE7 still gives the same problem

FireFox , IE8 is fixed.
Comment 4 Calcey QA 2010-02-16 10:16:57 UTC
Tested link: http://prototype.wikimedia.org/deployment-en/
Version : r62529

Bug still available in IE7
Comment 5 Calcey QA 2010-03-12 08:45:10 UTC
Bug no longer reproducible in the prototype environment.
Comment 6 Calcey QA 2010-04-11 07:15:54 UTC
When the user click on Bulleted item list 3 times below will be the output

* 
* Bulleted list item
* Bulleted list item

First time it replace the text and in other hits it's not. 

Checked on FF 3.5.
Comment 7 Mark A. Hershberger 2011-04-14 18:48:20 UTC
Closing per Comment 5

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links