Last modified: 2013-01-22 19:22:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21982 - Reader feedback generates bad png graphs on enwikinews
Reader feedback generates bad png graphs on enwikinews
Status: NEW
Product: MediaWiki extensions
Classification: Unclassified
ReaderFeedback (Other open bugs)
unspecified
All All
: Lowest major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://upload.wikimedia.org/wikinews/...
:
Depends on:
Blocks: svg
  Show dependency treegraph
 
Reported: 2010-01-01 06:46 UTC by Bawolff (Brian Wolff)
Modified: 2013-01-22 19:22 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bawolff (Brian Wolff) 2010-01-01 06:46:35 UTC
Reader feedback extension is generating bad png graphs (svg is fine). Letters are replaced with boxes, and there is no graph lines. This is only for some png graphs. (sorry this is not the greatest bug report, but the problem seems random to me).
Comment 1 Aaron Schulz 2010-01-01 19:28:49 UTC
This has been there for months but there seems to be no reason why the MW core SVG renderer fails to make the pngs to svgs. The SVGs are fine and the syntax is valid (1.1).
Comment 2 Bawolff (Brian Wolff) 2010-01-02 04:33:41 UTC
I look at those graphs every so often. This is a new issue. 
Comment 3 Bawolff (Brian Wolff) 2010-01-02 11:11:12 UTC
Hmm, now it appears to have gone away. Perhaps it was a one-time issue
Comment 4 Bawolff (Brian Wolff) 2010-01-02 11:21:38 UTC
Ignore my last comment, It is still present, just only on the longer term graphs (it appears).

It appears to be a problem with how the extension calls the svg renderer. Compare:
http://upload.wikimedia.org/wikinews/en/graphs/3/reliability/l1095d.png (reliability graph last 3 months as png generated by extension)
and
https://secure.wikimedia.org/wikinews/en/wiki/File:Reliabality-wn-main_page.svg (svg reliability graph, uploaded to wikinews, and turned into a png via the normal svg image renderer).

The two images are very different.
Comment 5 Aaron Schulz 2010-01-03 03:56:08 UTC
Core/extensions both call $svgHandler->rasterize( $srcPath, $dstPath, $physicalWidth, $physicalHeight );
Comment 6 Aaron Schulz 2010-01-03 04:26:36 UTC
I looking into xml namespace issues as a possibility. Uploaded files have some stripping that takes place on upload.
Comment 7 Aaron Schulz 2010-01-03 04:52:15 UTC
(In reply to comment #6)
> I looking into xml namespace issues as a possibility. Uploaded files have some
> stripping that takes place on upload.

Nevermind, those are just for temp vars for virus checks.
Comment 8 Aaron Schulz 2010-01-03 07:13:09 UTC
The good png image (https://secure.wikimedia.org/wikinews/en/wiki/File:Reliabality-wn-main_page.svg) is a thumbnail that goes through the 404 handler, thumb-handler.php, and thumb.php on the image scaling cluster. The bad one is rendered on the main boxes. Imagemagik may have different versions/constrains/settings on them.
Comment 9 Aaron Schulz 2010-01-03 08:07:10 UTC
Gah, rsvg not imagemagick
Comment 10 Derk-Jan Hartman 2012-10-26 09:40:11 UTC
I can't seem to get a graph out of https://en.wikinews.org/w/index.php?title=Special%3ARatingHistory&target=Main_Page&period=1095 anymore. Is that functionality no longer supported ?

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links