Last modified: 2013-06-18 16:00:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21962 - Run refreshLinks.php --redirects-only on all wikis
Run refreshLinks.php --redirects-only on all wikis
Status: RESOLVED DUPLICATE of bug 27480
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: shell
Depends on:
Blocks: 16660 29782
  Show dependency treegraph
 
Reported: 2009-12-29 02:55 UTC by Danny B.
Modified: 2013-06-18 16:00 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Danny B. 2009-12-29 02:55:49 UTC
SELECT rd_from, page_id FROM redirect LEFT JOIN page ON rd_from = page_id WHERE page_id IS NULL;

The above query should never return a row, but it does - redirect table contains rows with inexistent pages, thus the table is apparently during some action(s) not being updated.

Redirect tables should be cleaned up after fix as well by deleting of improper entries.
Comment 1 Merlijn van Deen (test) 2010-01-02 02:51:30 UTC

*** This bug has been marked as a duplicate of bug 16112 ***
Comment 2 Danny B. 2010-01-04 00:38:38 UTC
I don't think it's a dupe, it's rather related.
Comment 3 Merlijn van Deen (test) 2010-01-04 08:16:28 UTC
I'm sorry, my mistake. It is a different problem indeed. However, the problem does automatically get solved when bug 16112 is fixed (same script).
Comment 4 Roan Kattouw 2010-04-19 08:24:59 UTC
Mass-unassigning shell bugs from myself to Rob; I used to do them once, but I
don't have time for them any more.
Comment 5 Sam Reed (reedy) 2011-09-14 21:12:54 UTC

*** This bug has been marked as a duplicate of bug 27480 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links