Last modified: 2009-12-24 12:02:01 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21841 - <ref name="someReferenceName">some reference</ref> creates rows in pagelinks with a pl_title = ''
<ref name="someReferenceName">some reference</ref> creates rows in pagelinks ...
Status: RESOLVED DUPLICATE of bug 16965
Product: MediaWiki extensions
Classification: Unclassified
Cite (Other open bugs)
unspecified
PC All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-14 00:36 UTC by daniel macey
Modified: 2009-12-24 12:02 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description daniel macey 2009-12-14 00:36:47 UTC
Using Cite and <ref> tags invalid rows are created in the pagelinks table.

These rows are invalid because they have a pl_title = ''.

This -may- break Special:MostLinkedPages page (a fix was put in to stop invalid titles breaking the page) - see #18943, #17751 and #17713 for more information on this flavor of issue.

To identify broken pages:

SELECT page.*
FROM
  wikidb.page page left join
  wikidb.pagelinks p on page.page_id = p.pl_from
where p.pl_title = '';


To reproduce:
1. Run the query above to ensure you have no broken page titles
2. Edit a page and add <ref name="test">http://google.com, a search engine</ref>
3. Re-run the query

I'm not confident this is a bug with the Cite extension or whether it is the engine but thought it most appropriate here.

I am assuming blank rows are an issue because issue #17713 says "Invalid database rows worry me" in regards to rows with an empty pl_title
Comment 1 Sam Reed (reedy) 2009-12-14 07:28:24 UTC
Can't imagine this is xp specific..
Comment 2 Alex Z. 2009-12-15 01:20:25 UTC
I can't reproduce this; what version are you using?
Comment 3 daniel macey 2009-12-15 01:24:43 UTC
(In reply to comment #2)
> I can't reproduce this; what version are you using?
> 

MediaWiki Version 1.14.0
Cite MW1.14-r45577
Comment 4 Priyanka Dhanda 2009-12-24 02:06:54 UTC
Hi Daniel,
I cannot reproduce this either. Is it possible for you to easily this on a later version ?
-p
Comment 5 Roan Kattouw 2009-12-24 12:02:01 UTC

*** This bug has been marked as a duplicate of bug 16965 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links