Last modified: 2009-12-02 14:34:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21741 - Revision History stops at 500 revisions, with no "Older" option.
Revision History stops at 500 revisions, with no "Older" option.
Status: RESOLVED DUPLICATE of bug 2930
Product: MediaWiki
Classification: Unclassified
History/Diffs (Other open bugs)
1.16.x
All All
: Normal major (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-02 06:45 UTC by Bright Soo
Modified: 2009-12-02 14:34 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Bright Soo 2009-12-02 06:45:49 UTC
1. An overall description of the bug

When viewing the history page at the URL above, clicking on "500" results in a list of 500 changes, with no "Older" link available, even though older revisions exist.

   2. Steps to reproduce

When logged in (as Bsoo), going to the history page lists 500 results immediately due to my account setting.  There is no "Older" link.  Clicking on the oldest entry (bottom of list),
  http://en.wikipedia.org/w/index.php?title=Orbital_resonance&oldid=271925
reveals a clickable "← Previous revision" link, i.e. yet older revisions exist.  Note that when logged in I am in Wikipedia Beta.

When logged off, steps to reproduce bug is same, except user would click on "500" first.  When I tested this, I am NOT in Wikipedia Beta.

   3. Expected result

One would expect to see "Older" links available.

   4. Actual result

No "Older" links.  Page displayed as if it contained the entire history (it didn't).

   5. Additional information

None.
Comment 1 Bright Soo 2009-12-02 06:58:37 UTC
Forgot to add that I tested this in IE7 also.
Comment 2 P.Copp 2009-12-02 14:34:20 UTC
There aren't more revisions. The bug is that edit history is sorted by timestamp whereas the order when viewing diffs is determined by revision id.

*** This bug has been marked as a duplicate of bug 2930 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links