Last modified: 2009-12-17 20:33:20 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21535 - Special:RecentChanges RSS feed ignores namespace
Special:RecentChanges RSS feed ignores namespace
Status: RESOLVED FIXED
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.16.x
All All
: Normal normal (vote)
: ---
Assigned To: Nobody - You can work on this!
: patch, patch-need-review
: 6132 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-16 17:49 UTC by Dan Barrett
Modified: 2009-12-17 20:33 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Patch for adding namespace value to the cache key used for recent changes RSS. (2.19 KB, patch)
2009-12-15 15:00 UTC, Craig Box
Details

Description Dan Barrett 2009-11-16 17:49:21 UTC
On Special:RecentChanges, the parameter "namespace" filters the results. However, when feed=rss is used, the namespace parameter is ignored.

Bug is present in 1.16alpha-wmf (r59133) on Wikipedia, as well as 1.15.1.

Case study:

Uses namespace:
http://en.wikipedia.org/wiki/Special:RecentChanges?namespace=2

Ignores namespace (bug):
http://en.wikipedia.org/wiki/Special:RecentChanges?namespace=2&feed=rss
Comment 1 Dan Barrett 2009-11-16 17:50:00 UTC
In contrast, Special:NewPages respects the "namespace" parameter for RSS.
Comment 2 Craig Box 2009-12-15 15:00:03 UTC
Created attachment 6883 [details]
Patch for adding namespace value to the cache key used for recent changes RSS.

The difference is that Special:NewPages always generates a feed; Special:RecentChanges uses the ChangesFeed class, which caches its results.  If you alter the feedSetup() function to include the namespace parameter, the cache will then return you the results from whatever namespace you first hit, for the cache validity period, even when you have changed the namespace parameter.  To work around _that_, we add the namespace value to the cache key.

Attached is a patch for this issue. I can't see any reason why using namespace as a cache parameter is a bad thing, so if anyone could weigh in here, please do.
Comment 3 Happy-melon 2009-12-17 15:21:16 UTC
Looks good to me, but RSS and caching are not my strong suits.
Comment 4 Happy-melon 2009-12-17 15:43:01 UTC
Committed in r60163.
Comment 5 Raimond Spekking 2009-12-17 20:33:20 UTC
*** Bug 6132 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links