Last modified: 2010-07-22 12:01:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21492 - Toolbar buttons insert text on top in IE
Toolbar buttons insert text on top in IE
Status: RESOLVED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
Macintosh Windows XP
: Normal blocker (vote)
: ---
Assigned To: Trevor Parscal
:
: 21539 21567 (view as bug list)
Depends on:
Blocks: 24493
  Show dependency treegraph
 
Reported: 2009-11-12 19:55 UTC by howief
Modified: 2010-07-22 12:01 UTC (History)
5 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description howief 2009-11-12 19:55:44 UTC
Toolbar bugs on enwiki:

1. When I highlight text and then bold/italicize, it inserts the bold/italicized text somewhere else in the doc (vs simply inserting the markup around the text). 

2.  The toolbar links (eg advanced, help) don't expand anything when clicked.  I've tried refreshing the window but that doesn't help.  

Both these are working fine on dewiki in comparison.
Comment 1 Roan Kattouw 2009-11-12 23:56:33 UTC
(In reply to comment #0)
> Toolbar bugs on enwiki:
> 
> 1. When I highlight text and then bold/italicize, it inserts the
> bold/italicized text somewhere else in the doc (vs simply inserting the markup
> around the text). 
> 
> 2.  The toolbar links (eg advanced, help) don't expand anything when clicked. 
> I've tried refreshing the window but that doesn't help.  
> 
Number 2 has been fixed.
Comment 2 Roan Kattouw 2009-11-16 21:18:45 UTC
*** Bug 21539 has been marked as a duplicate of this bug. ***
Comment 3 Adam Miller 2009-11-16 23:09:04 UTC
Roan, when I commented out the call to $(this).focus() on line 87 of
jquery.textSelection.js, it mostly fixes problem number one in IE7. The text is
inserted at the correct location, but it still jumps the cursor to a seemingly
arbitrary location after the insert is preformed.
Comment 4 Roan Kattouw 2009-11-17 23:13:32 UTC
Fixed in r59185.
Comment 5 Roan Kattouw 2009-11-19 11:45:48 UTC
*** Bug 21567 has been marked as a duplicate of this bug. ***
Comment 6 Roan Kattouw 2009-11-19 11:46:21 UTC
Reports that this is not fixed on dewiki, see bug 21567. Will investigate.
Comment 7 Trevor Parscal 2010-01-26 00:21:42 UTC
Since we are no longer using a textarea, this has been solved.
Comment 8 Roan Kattouw 2010-01-26 13:41:27 UTC
(In reply to comment #7)
> Since we are no longer using a textarea, this has been solved.

You'd be surprised: http://www.mediawiki.org/wiki/User:Catrope/Bizarre_browser_bugs#Loss_of_selection_in_content-editable_iframe

Changing resolution to FIXED, because that's basically what we did by introducing the iframe.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links