Last modified: 2012-10-04 09:53:04 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21341 - #time ParserFunctions output for Bengali Wiki
#time ParserFunctions output for Bengali Wiki
Status: RESOLVED INVALID
Product: MediaWiki extensions
Classification: Unclassified
ParserFunctions (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://bn.wikipedia.org/wiki/user:Jay...
:
Depends on:
Blocks: 40760
  Show dependency treegraph
 
Reported: 2009-10-29 08:21 UTC by Jayanta Nath
Modified: 2012-10-04 09:53 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Jayanta Nath 2009-10-29 08:21:53 UTC
Dear we have an issue with #time ParserFunctions and their calculation with #expr ParserFunctions of our all out time based calculation in all templates.

The issue is #time: ParserFunctions output is Bengali numeric number which is non-calculable.

see the example....
{{#time: YmdHis}}= ২০০৯১০২৯০৭১৯৫৭ (output is Bengali numeric number)

then when we use this below coding to any templates....we got error.... 

{{#expr:{{#time: YmdHis}}/1000000 round 0}}=এক্সপ্রেশন ত্রুটি: অপরিচিত বিরামচিহ্ন ক্যারেক্টার "�"

But when I add this code output is roman number
{{#expr: ( 27 * 46 / pi ) round 2 }}=395.34

see this link
http://bn.wikipedia.org/wiki/user:Jayantanth/Sandbox

This problem is also shown all other Indian languages like Hindi wikipedia

http://hi.wikipedia.org/wiki/user:Jayantanth/Sandbox



http://en.wikipedia.org/wiki/User:Jayantanth/Sandbox
Comment 1 Alexandre Emsenhuber [IAlex] 2009-10-29 08:53:12 UTC
You need to put the "xN" flag at the beginning of the time format:
{{#expr:{{#time:xNYmdHis}}/1000000 round 0}}
works correctly.
Comment 2 Jayanta Nath 2009-10-29 09:27:19 UTC
Thank you Alex. But this small things have to be updated in 
http://www.mediawiki.org/wiki/Help:ParserFunctions
Comment 3 Jayanta Nath 2009-10-29 09:47:36 UTC
Sorry dear I had just overlook below the table saying that 

Flags
xn 	Format the next numeric code as a raw ASCII number. 	In the Hindi language, {{#time:H, xnH}} produces ०६, 06
xN 	Like xn, but as a toggled flag, which endures until the end of the string or until the next appearance of xN in the string.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links