Last modified: 2012-04-19 21:43:42 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21340 - Header : Creates invalid levels when the header change by selecting the text
Header : Creates invalid levels when the header change by selecting the text
Status: CLOSED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC All
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-29 07:41 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screen print of the error (87.81 KB, application/pdf)
2009-10-29 07:41 UTC, Calcey QA
Details

Description Calcey QA 2009-10-29 07:41:27 UTC
Created attachment 6734 [details]
Screen print of the error

Reporting against Babaco Release : r58199

Steps to Reproduce ::
1) Select a random page
2) Edit page
3) Create headings
4) Select heading text and change a heading level
Level 3 to level 4
<<A new heading is created of level 7>>

5) Undo changes
6) Select heading text and change a heading level
Level 3 to level 4
<<A new heading is created of level 6 and the navigation TOC also display the invalid>>
<<Level 1 and Level 3 has come to one level in the navigation TOC>>


Expected Outcome::
All the invalid levels should not display in Navigation TOC
If the text is selected, it should either validate whether the text is of header type or ignor the text convert to headers


Test Environment::
Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.27 Safari/532.0

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0 (.NET CLR 3.5.30729)

Browser (User-Agent): 	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Roan Kattouw 2009-10-29 09:17:19 UTC
This bug is two-fold: first, there's the issue that if you select just the header text instead of the entire header, changing the header level doesn't work the way you expect. We could maybe look at the whole line instead of just the selection, I'll discuss this.

Second, there's the issue of the following text:
== Foo ==
====== Bar ======
==== Foo ====
===== Bar =====
displaying both "Foo"s at the same indentation level, as well as both "Bar"s. This is not a bug: if you click Show preview, that's exactly what the table of contents in the article will look like, we're just mimicking that. The individual headers in this case are not invalid; the one in the first test case was, because it was a level 7 header (valid header levels are 1-6).
Comment 2 Calcey QA 2010-03-12 09:03:19 UTC
Closing the bug as per comment 1

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links