Last modified: 2012-12-15 10:52:25 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21297 - Collapsing Tabs: 600px x 480px hides "Read" section
Collapsing Tabs: 600px x 480px hides "Read" section
Status: RESOLVED DUPLICATE of bug 20234
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Lowest minor (vote)
: ---
Assigned To: Nobody - You can work on this!
:
: 24150 (view as bug list)
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-26 10:00 UTC by Calcey QA
Modified: 2012-12-15 10:52 UTC (History)
7 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screen print of the error (383.85 KB, application/pdf)
2009-10-26 10:00 UTC, Calcey QA
Details
Screen prints (324.80 KB, application/pdf)
2009-10-26 10:38 UTC, Calcey QA
Details

Description Calcey QA 2009-10-26 10:00:45 UTC
Created attachment 6719 [details]
Screen print of the error

Reporting against Babaco Release : r57957

Steps to Reproduce ::

1) Login to both English version and Sinhala versions
2) Make resolution for 600 x 480 
<<Section “Read” is not visible in Sinhala wiki page>>

Expected Outcome::
Read and Edit sections should not be hidden or collapse


Test Environment::
Browser (User-Agent): 	Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Calcey QA 2009-10-26 10:37:24 UTC
Same happen for the resolutions : 400 x 300 / 512 x 380 / 640 x 400 / 640 x 480 

Test Environment::
Browser (User-Agent): Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.14) Gecko/2009090905 Fedora/3.0.14-1.fc10 Firefox/3.0.14
Comment 2 Calcey QA 2009-10-26 10:38:19 UTC
Created attachment 6720 [details]
Screen prints
Comment 3 Roan Kattouw 2009-10-26 17:16:42 UTC
CollapsibleTabs isn't hiding it, it's just that there's no room for it to be shown anywhere, so it slides under the Page/Discussion tabs. There will always be screen sizes where the layout looks like crap without adjusting the text size.
Comment 4 Trevor Parscal 2009-10-26 17:36:30 UTC
The collapsible tabs do not hide the read and view in these screen-shots, the read and view tabs are merely obscured by the article and discussion tabs. Before the collapsible tabs, any resolution below 800x600 was in danger of causing these kinds of tab-obscuring layout issues, especially in languages with long words like German and Polish. The collapsible tabs automatically hides some of the tabs, making that minimum resolution much closer to 640x480, but that's not the ONLY reason for it. The other reason is that it lets us put extra items at the tab level, like "Add Topic" for most users.

I think we may want to solve this problem by setting a minimum width. The CSS min-width property is not generally supported right now, so other tricks like using a 1px tall 800px wide transparent png on the page may work.
Comment 5 Calcey QA 2009-10-27 04:58:14 UTC
(In reply to comment #4)
> I think we may want to solve this problem by setting a minimum width. The CSS
> min-width property is not generally supported right now, so other tricks like
> using a 1px tall 800px wide transparent png on the page may work.
> 

Considering the above comment, changing the status of the bug from Resolved Invalid to Resolved later.
Comment 6 Andre Klapper 2012-12-14 13:41:13 UTC
[Reopening to get rid of LATER resolution]
Comment 7 Andre Klapper 2012-12-14 13:41:30 UTC
*** Bug 24150 has been marked as a duplicate of this bug. ***
Comment 8 Krinkle 2012-12-14 18:13:02 UTC
Re-closing, this bug is regarding the Babaco release of the Usability Initiative, which has been discontinued long ago.

If this bug is also present in the Vector release, please file a new bug against the Vector skin in MediaWiki core, the Vector extension or the WikiEditor extension respectively.
Comment 9 Michael M. 2012-12-15 08:50:55 UTC
(In reply to comment #8)
> If this bug is also present in the Vector release, please file a new bug
> against the Vector skin in MediaWiki core, the Vector extension or the
> WikiEditor extension respectively.

Actually, this has been done long before in bug 20234, but obviously choosing the right component didn't help to get this year old bug fixed.
Comment 10 Andre Klapper 2012-12-15 10:52:25 UTC
(In reply to comment #8)
> Re-closing, this bug is regarding the Babaco release of the Usability
> Initiative, which has been discontinued long ago.

Doesn't matter if the issue still exists.
Marking as dup of bug 20234.

*** This bug has been marked as a duplicate of bug 20234 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links