Last modified: 2012-04-19 21:43:27 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21291 - Table dialog doesn't restore properly after having been closed
Table dialog doesn't restore properly after having been closed
Status: CLOSED WORKSFORME
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC All
: Normal minor (vote)
: ---
Assigned To: Trevor Parscal
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-26 05:45 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screen print of the error (140.25 KB, application/pdf)
2009-10-26 05:45 UTC, Calcey QA
Details
Screen print of the error msg (52.58 KB, application/pdf)
2009-10-29 08:02 UTC, Calcey QA
Details

Description Calcey QA 2009-10-26 05:45:23 UTC
Created attachment 6715 [details]
Screen print of the error

Reporting against Babaco Release : r57957

Steps to Reproduce ::
1)	Select a random page
2)	Edit the page
3)	Click to insert a table
4)	Select “Make table sortable” option
5)	De-select  “Include header row” option
6)	Make the table create throw an error
7)	Press “Esc”/Cancel to close the screen
8)	Click on Table icon again
9)	Select “Include header row” option`
<<Header text is two lines>>

10)	Press Cancel/Esc to close the window
11)	Click on table link and it shows the headers in un-wrap mode


Expected Outcome::
Table header should be the same for all occurrences


Test Environment::
In all browsers
Comment 1 Calcey QA 2009-10-29 08:02:03 UTC
Created attachment 6735 [details]
Screen print of the error msg
Comment 2 Calcey QA 2009-10-29 08:04:47 UTC
Attachment id=6735 is not valid to this bug.
Comment 3 Roan Kattouw 2009-10-29 11:13:55 UTC
Fixed in r58309.
Comment 4 Calcey QA 2009-11-12 07:36:39 UTC
Reopen the bug since sorting feature not in r58867
Comment 5 Roan Kattouw 2009-11-12 08:04:19 UTC
(In reply to comment #4)
> Reopen the bug since sorting feature not in r58867
> 

Re-closing. The sorting feature is only in the new table dialog, you're looking at the old one.
Comment 6 Calcey QA 2010-01-25 05:22:57 UTC
Re Open the bug since the given scenario of change table header is still exist
Comment 7 Roan Kattouw 2010-01-25 10:06:47 UTC
(In reply to comment #6)
> Re Open the bug since the given scenario of change table header is still exist

Can't reproduce this.

This is what I tried, please verify I understood the report correctly:

1. Open the table dialog. "Header Text" is broken over two lines
2. Uncheck "Add header row"
3. Close the dialog
4. Open the dialog again.
5. Check "Add header row". "Header Text" is, again, broken over two lines
6. Close the dialog
7. Open the dialog. "Header Text" is still on two lines, while you say it's on one
Comment 8 Calcey QA 2010-01-25 11:11:34 UTC
The steps you followed is correct. But for the first time open I get the Header text in one line. Text in one line and the sorting sign in the next. And on 2nd return the Header is in one line and Text and Sorting sign is in the next.

I use the following browsers to re-check the bug details.

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 (.NET CLR 3.5.30729)
Time and Date: 	3:57:59 PM - Monday, January 25, 2010
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled 


Browser (User-Agent): 	Opera/9.63 (Windows NT 6.0; U; en) Presto/2.1.1
Time and Date: 	4:00:48 PM - Monday, January 25, 2010
Javascript:	Enabled
Cookies Enabled:	Enabled 
Java Enabled:	Enabled


Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.38 Safari/532.0
Time and Date:	4:09:46 PM - Monday, January 25, 2010
Javascript:	Enabled
Cookies Enabled:	Enabled
Java Enabled:	Enabled
Comment 9 Roan Kattouw 2010-01-25 14:29:59 UTC
(In reply to comment #8)
> The steps you followed is correct. But for the first time open I get the Header
> text in one line. Text in one line and the sorting sign in the next. And on 2nd
> return the Header is in one line and Text and Sorting sign is in the next.
> 
Interesting; when I open the dialog I get the text on two lines right away.

I'm inclined to say this isn't a big deal, though.
Comment 10 Roan Kattouw 2010-03-16 17:52:19 UTC
This seems to be some weird browser quirk or something; it can't get it to happen for me, and it's a really small issue anyway.
Comment 11 Calcey QA 2010-03-17 06:14:19 UTC
Closing the bug as of comment 10

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links