Last modified: 2009-11-03 09:11:15 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21231 - print-out of subproperty values
print-out of subproperty values
Status: RESOLVED DUPLICATE of bug 12822
Product: MediaWiki extensions
Classification: Unclassified
Semantic MediaWiki (Other open bugs)
unspecified
All All
: Normal minor (vote)
: ---
Assigned To: Markus Krötzsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-22 11:43 UTC by Philipp
Modified: 2009-11-03 09:11 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Philipp 2009-10-22 11:43:30 UTC
In SMW you can state a property as subproperty of a more general property.
E.g. you can state for Property:HasProjectLeader: [[subproperty of::Property:HasResponsiblePerson]].

Now assume you want to query for all things having a responsible person and print out the responsible person:

{{#ask: [[HasResponsiblePerson::+]] | ?HasResponsiblePerson}}

You also get pages using more specialized properties (e.g. HasProjectLeader); however the printout does not work if a more specialized property is used.
Comment 1 Philipp 2009-10-22 11:53:43 UTC
Another example would be:
{{#ask:[[Category:Task]] |?Assignee.Firstname}}

The printout of a chained property value might be e.g. useful, when ?Assignee does not contain a meaningful name, but e.g. a person ID.
Comment 2 Philipp 2009-10-22 12:04:05 UTC
aaah ignore my last comment, it was meant for the enhancement of printing out chained property values
(see https://bugzilla.wikimedia.org/show_bug.cgi?id=21232).
Comment 3 Markus Krötzsch 2009-11-03 09:11:15 UTC

*** This bug has been marked as a duplicate of bug 12822 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links