Last modified: 2012-04-19 21:43:35 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21203 - Collapsing tabs not listing all in the drop down except for read and edit
Collapsing tabs not listing all in the drop down except for read and edit
Status: CLOSED INVALID
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
All All
: Normal critical (vote)
: ---
Assigned To: Adam Miller
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-20 10:15 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Screen print of the error (84.59 KB, application/pdf)
2009-10-20 10:15 UTC, Calcey QA
Details
Screen print of the error (93.34 KB, application/pdf)
2009-11-04 04:26 UTC, Calcey QA
Details
Screen prints of the error (105.40 KB, application/pdf)
2009-11-13 05:14 UTC, Calcey QA
Details

Description Calcey QA 2009-10-20 10:15:36 UTC
Created attachment 6691 [details]
Screen print of the error

Reporting against Babaco Release : r57727

Steps to Reproduce ::

1) Login to http://prototype.wikimedia.org/en.wikipedia.org/Main_Page
2) Select a random page
3) Make the window smaller
<<Only one tab is shown in the drop down.>>

Expected Outcome::
All the tabs other than read and edit should shown in the drop down


Test Environment::

Browser (User-Agent): 	Opera/9.63 (Windows NT 6.0; U; en) Presto/2.1.1

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9) Gecko/2008052906 Firefox/3.0 (.NET CLR 3.5.30729)

Browser (User-Agent): Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3
Comment 1 Roan Kattouw 2009-10-20 18:06:17 UTC
The source of this seems to be that CollapsibleTabs only collapses one tab at a time, which breaks for sudden big resizings like maximize<->normal size.
Comment 2 Adam Miller 2009-10-20 19:41:42 UTC
The real reason nothing else is collapsing is because we're only instructing it to collapse the view history item. 

Collapsible items are identified by a css selector, and by default it's set to 'li.collapsible'. Vector is only applying that to view history currently. I will inquire if this is not the desired functionality, will apply the change if it's needed. 

There WAS a bug in the javascript which I just corrected in r57953 which was preventing multiple tabs from collapsing on one resize event, but that will not alter the functionality here since we only have one tab marked as collapsible. 



Comment 3 Roan Kattouw 2009-10-20 20:11:49 UTC
(In reply to comment #2)
> The real reason nothing else is collapsing is because we're only instructing it
> to collapse the view history item. 
> 
> Collapsible items are identified by a css selector, and by default it's set to
> 'li.collapsible'. Vector is only applying that to view history currently. I
> will inquire if this is not the desired functionality, will apply the change if
> it's needed. 
> 
> There WAS a bug in the javascript which I just corrected in r57953 which was
> preventing multiple tabs from collapsing on one resize event, but that will not
> alter the functionality here since we only have one tab marked as collapsible. 
> 

No we don't, we also have the Add topic tab on talk pages, which is also collapsible, so the JS bug you fixed actually did have a real effect.
Comment 4 Calcey QA 2009-11-04 04:22:45 UTC
The issue still exists
Comment 5 Calcey QA 2009-11-04 04:26:19 UTC
Created attachment 6750 [details]
Screen print of the error
Comment 6 Adam Miller 2009-11-05 18:56:59 UTC
I can't replicate this. The View History tab moves into the drop down just fine for me. The Watch/Unwatch icon is not intended to move, so I'm not sure what the problem is. 

Comment 7 Roan Kattouw 2009-11-12 16:57:26 UTC
(In reply to comment #6)
> I can't replicate this. The View History tab moves into the drop down just fine
> for me. The Watch/Unwatch icon is not intended to move, so I'm not sure what
> the problem is. 
> 

Could Calcey confirm whether this is issue is still present?
Comment 8 Naoko Komura 2009-11-12 19:12:35 UTC
(In reply to comment #5)
> Created an attachment (id=6750) [details]
> Screen print of the error
> 

Could we have more information about this report?  What is the brower and OS when the issue was encountered?  What was the resolution?
Comment 9 Calcey QA 2009-11-13 05:14:09 UTC
Created attachment 6777 [details]
Screen prints of the error
Comment 10 Calcey QA 2009-11-13 05:16:56 UTC
Resolution : 720 x 576

Please refer to the attachment id 6777

In the normal resolution there are 04 tabs as Read,View Source,View History and the Star
When the screen come down to a resolution less than 800 x 600 then only View History goes to the drop down. 

As we understand the requirement "the window resolutions is scaled down to the point when the tabs starts overlapping.  Tabs will be tucked away in the drop down menu except "Read" and "Edit" tabs"
So the View Source also should be listed in the drop down but it isn't. According to the comment #6 the Start also should not be listed also. 

That is the error we have pointed. 
Comment 11 Roan Kattouw 2009-11-13 12:03:11 UTC
(In reply to comment #10)
> Resolution : 720 x 576
> 
> Please refer to the attachment id 6777
> 
> In the normal resolution there are 04 tabs as Read,View Source,View History and
> the Star
> When the screen come down to a resolution less than 800 x 600 then only View
> History goes to the drop down. 
> 
> As we understand the requirement "the window resolutions is scaled down to the
> point when the tabs starts overlapping.  Tabs will be tucked away in the drop
> down menu except "Read" and "Edit" tabs"
> So the View Source also should be listed in the drop down but it isn't.
> According to the comment #6 the Start also should not be listed also. 
> 
This is partly a misunderstanding, and partly a misstatement of the feature. The View Source tab is really the Edit tab with another caption (it points to the same URL), therefore it's not collapsed. The watch star is also not collapsed by design, since it's so small.
Comment 12 Calcey QA 2009-11-13 12:50:54 UTC
Close as of Comment  #11 

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links