Last modified: 2012-04-19 21:43:03 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21202 - Search icon shall be triggered when 'Enter' button is pressed.
Search icon shall be triggered when 'Enter' button is pressed.
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC All
: Normal normal (vote)
: ---
Assigned To: Roan Kattouw
http://usability.wikimedia.org/wiki/P...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-20 09:37 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-10-20 09:37:41 UTC
Reporting against build r57727

Steps to reproduce :
1) Start editing a new page.
2) Enter 'Wal' in the search text box.
3) Select 'Wales' word from the suggestion list using arrow keys.
4) Press enter button.

<<Selected 'Wales' word entered into the search text box>>

Expected Outcome::
Should triggered the search functionality when press the 'Enter' button.

Test Environment::
Can be reproduce the bug in all the browser versions.
Comment 1 Roan Kattouw 2009-10-20 16:34:44 UTC
This is expected behavior: when selecting a suggestion, Enter means "enter this suggestion into the textbox". You need to press Enter again to actually search for the word. This is how the 'old' search works, and we saw no reason to change it.
Comment 2 Calcey QA 2009-10-21 05:42:04 UTC
The wikipedia production site "search" is working with one enter press and we compared this search component with that. If the search behave in two different ways in a one site will not be user friendly.

Comment 3 Roan Kattouw 2009-10-27 15:45:59 UTC
Fixed in r58198.
Comment 4 Calcey QA 2009-10-28 08:02:56 UTC
Work in http://prototype.wikimedia.org/en.wikipedia.org/Main_Page where the version is r58234

NOT work in http://prototype.wikimedia.org/deployment/Main_Page where the version is r58199
Comment 5 Roan Kattouw 2009-10-28 12:09:49 UTC
Forgot to deploy this one as well; done now and works for me.
Comment 6 Calcey QA 2009-10-29 03:45:35 UTC
Verified and closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links