Last modified: 2012-04-19 21:42:58 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 21125 - Search & Replace: Number of replaces made is incorrect.
Search & Replace: Number of replaces made is incorrect.
Status: CLOSED DUPLICATE of bug 21135
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/si-wp/...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-13 12:23 UTC by Calcey QA
Modified: 2012-04-19 21:42 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Bug Desc screen shot (238.63 KB, application/pdf)
2009-10-13 12:23 UTC, Calcey QA
Details

Description Calcey QA 2009-10-13 12:23:13 UTC
Created attachment 6666 [details]
Bug Desc screen shot

Reporting against Babaco Release. (Hosted on hhttp://prototype.wikimedia.org/si-wp/)

Steps to Reproduce ::
1)Navigate to a page and click Edit link.
2)Enter following text in the text area.
==හිමිකම් පෙළ 1==
===හිමිකම් පෙළ 2===
====හිමිකම් පෙළ 3====
=====හිමිකම් පෙළ 4=====
3)Click Search and replace icon.
4)Set "හිමිකම්" in 'සොයන්නේ' field and set 'ශීර්ෂ' in 'කුමක් සමඟ ද ප්‍රතිස්ථාපනය කරනු ලබන්නේ' field.
5)Now click on "Replace ALL" button.

<<'එක් ප්‍රතිස්ථාපනයක් සිදු කරන ලදී.' message displayed>>

Expected Outcome::
Should display 'ප්‍රතිස්ථාපන 4ක් සිදු කරන ලදී.'

Test Environment::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)

Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30618; InfoPath.2) 

Browser (User-Agent): 	Opera/9.80 (Windows NT 6.0; U; en) Presto/2.2.15 Version/10.00

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9.1

Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.0 (KHTML, like Gecko) Chrome/3.0.195.25 Safari/532.0
Comment 1 Roan Kattouw 2009-10-14 21:38:21 UTC
(In reply to comment #0)
> ==හිමිකම් පෙළ 1==
> ===හිමිකම් පෙළ 2===
> ====හිමිකම් පෙළ 3====
> =====හිමිකම් පෙළ 4=====
> 3)Click Search and replace icon.
> 4)Set "හිමිකම්" in 'සොයන්නේ' field and set
> 'ශීර්ෂ' in 'කුමක් සමඟ ද
> ප්‍රතිස්ථාපනය කරනු ලබන්නේ' field.
> 5)Now click on "Replace ALL" button.
> 
> <<'එක් ප්‍රතිස්ථාපනයක් සිදු
> කරන ලදී.' message displayed>>
> 
> Expected Outcome::
> Should display 'ප්‍රතිස්ථාපන 4ක් සිදු
> කරන ලදී.'
> 
I apologize for asking, but could you provide an example in English? As I don't know this (Sinhali?) alphabet I have a lot more trouble identifying the correct number of occurrences of a word.
Comment 2 Calcey QA 2009-10-15 04:32:59 UTC
I apologize for the inconvenience caused. Please find the english version of the the above bug.

Steps to Reproduce ::
Steps to Reproduce ::
1)Navigate to a page and click Edit link.
2)Enter following text in the text area.
==test calcey 1==
===test calcey 2===
====test calcey 3====
=====test calcey 4=====
3)Click Search and replace icon.
4)Set "test" in 'search for' field and set
'home' in 'replace with' field.
5)Now click on "Replace ALL" button.

<<1 replacement done>>

Expected Outcome::
should display as '4 replacements has done'.
Comment 3 Roan Kattouw 2009-10-20 23:43:38 UTC

*** This bug has been marked as a duplicate of bug 21135 ***
Comment 4 Calcey QA 2009-10-21 09:26:30 UTC
The problem is fixed in Sinhala version r57958. 
Verified and closed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links