Last modified: 2012-04-19 21:43:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20946 - Search & Replace: Replace functionality is not working correctly in Safari
Search & Replace: Replace functionality is not working correctly in Safari
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
Macintosh other
: Normal major (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/deploy...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-10-02 12:25 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-10-02 12:25:08 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1) Start Editing an article.
2) Enter following texts in the article text area.
Home Test
Home Test
Home Test
Hone Test 
3) Click on Search and Replace icon.
4) Set Search for 'Test' and Replace as 'Calcey'
5) Click on Replace button 4 times.
<<Text changed to 
Home Calcey
Home TCalcey
Home TeCalcey
Hone TesCalcey
>>

Expected Outcome ::
Home Calcey
Home Calcey
Home Calcey
Hone Calcey

Test Environment (Client) ::
OS: MAC OS X Version 10.6.5
Browser (User-Agent):   Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_6;en-US) AppleWebKit/525.27.1 (KHTML, like Gecko) Version /3.2.1 Safari;
Comment 1 Roan Kattouw 2009-10-09 20:09:42 UTC
This was very likely caused by the same underlying issue as bug 21033, which means r57492 probably fixed this too.
Comment 2 Calcey QA 2009-10-13 11:48:36 UTC
verified and passed

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links