Last modified: 2012-04-19 21:43:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20895 - Navigable TOC : Headers added with header dropdown don't show up in IE8
Navigable TOC : Headers added with header dropdown don't show up in IE8
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal normal (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/deploy...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-30 09:34 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-30 09:34:16 UTC
Reporting against the build hosted on Staging environment.

Steps to reproduce :
1) Start editing a page with sections
2) Check navigable Table of content in the right side 
<<Navigable table of content is available >>

3)Include a heading using 'heading' drop down.
<<Entered link not visible in the Navigable TOC>>

Expected Outcome:
Navigable Table of Content shall be updated with the link.

Client Environment details ::
Browser (User-Agent):	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/530.17 (KHTML, like Gecko) Version/4.0 Safari/530.17
Javascript:	Enabled
Cookies Enabled:	Enabled
Java Enabled:	Enabled
Screen Width x Height:	1024 x 768
Screen Color Depth:	32
Comment 1 Calcey QA 2009-09-30 09:44:25 UTC
Client environment should corrected as follows.

Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; GTB6; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.30618) 
Time and Date:  3:13:25 PM - Wednesday, September 30, 2009 
Javascript: Enabled 
Cookies Enabled: Enabled  
Java Enabled: Enabled  
CPU class/type: CPU Class x86  
Screen Width x Height: 1024 x 768  
Screen Color Depth: 32
Comment 2 Roan Kattouw 2009-09-30 11:44:17 UTC
Tweaked summary to be more accurate; can you verify that it doesn't appear after waiting for one second (that's what happens for me on Firefox)?
Comment 3 Calcey QA 2009-10-22 06:10:39 UTC
This error still exists in following environments


Browser (User-Agent): 	Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0)

Browser (User-Agent):  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; SLCC1; .NET CLR 2.0.50727; Media Center PC 
5.0; .NET CLR 3.5.21022; .NET CLR 3.5.30729; .NET CLR 3.0.04506) 
Comment 4 Nimish Gautam 2010-01-27 00:39:28 UTC
There were some selection issues in IE when NTOC headings were being wrapped; I no longer see those issues...I think this might've been related
Comment 5 Roan Kattouw 2010-01-27 01:08:44 UTC
(In reply to comment #4)
> There were some selection issues in IE when NTOC headings were being wrapped; I
> no longer see those issues...I think this might've been related

I don't think so: this bug predates the introduction of the iframe.
Comment 6 Roan Kattouw 2010-01-27 16:01:32 UTC
This seems to have been fixed with the migration to the iframe, I can't reproduce this any more.
Comment 7 Calcey QA 2010-01-28 09:09:17 UTC
Verified and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links