Last modified: 2012-04-19 21:43:39 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20669 - Navigable TOC : The functionality is missing
Navigable TOC : The functionality is missing
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal blocker (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-17 07:46 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Reproducing Bug: Screen Shots (244.50 KB, application/msword)
2009-09-30 06:01 UTC, Calcey QA
Details
Browser Version pic (70.11 KB, image/png)
2009-09-30 06:18 UTC, Calcey QA
Details
NTOC missing... (174.53 KB, application/pdf)
2009-09-30 18:09 UTC, Naoko Komura
Details
Firebug showing javascript error causing the problem (315.73 KB, image/png)
2009-10-05 18:11 UTC, Trevor Parscal
Details

Description Calcey QA 2009-09-17 07:46:40 UTC
Reporting against the build hosted on Staging environment. (http://prototype.wikimedia.org)



Steps to reproduce :
1) Start editing a page with sections
2) Check navigable Table of content in the right side 

<<Navigable table of content is not available >>

Expected Outcome:
Navigable Table of Content shall be available 

Other Observations::
1) This functionality was available of staging environment yesterday (16th Sep 2009 )
2) This does not work in all browsers (IE, Firefox , Safari, Chrome and Opera)

Client Environment details ::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3 (.NET CLR 3.5.30729)
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1280 x 800
Screen Color Depth: 	32
Window Width: 	591 (46.2% of 1280)
Window Height: 	353 (44.1% of 800)
Comment 1 Roan Kattouw 2009-09-17 12:33:51 UTC
Config mistake, fixed now.
Comment 2 Calcey QA 2009-09-18 06:29:53 UTC
User can view the Navigable table of content for all the browser types.
Comment 3 Calcey QA 2009-09-22 10:38:00 UTC
Reporting against build r56748
(http://prototype.wikimedia.org)

Steps to reproduce :
1) Start editing a page with sections
2) Check navigable Table of content in the right side

Actual Outcome:
Navigable table of content is not available 
"Search and replace" section appears at the bottom of the page

Expected Outcome:
Navigable Table of Content shall be available
"Search and replace" window should be pop up, only when user click on the "Search and replace" icon.

Other Observations::
Not working on Firefox/2.0.
This does work in other Firefox versions (1 and 3)
This does work in all browsers (IE, Safari, Chrome and Opera)

Client Environment details ::
Browser (User-Agent): Firefox/2.0
Comment 4 Roan Kattouw 2009-09-22 14:25:54 UTC
(In reply to comment #3)
> Other Observations::
> Not working on Firefox/2.0.
> This does work in other Firefox versions (1 and 3)
> This does work in all browsers (IE, Safari, Chrome and Opera)
> 
> Client Environment details ::
> Browser (User-Agent): Firefox/2.0
> 

WORKSFORME with Firefox 2.0.0.16 on English prototype.
Comment 5 Calcey QA 2009-09-23 10:38:35 UTC
Facing same issues listed in comment 3.
Comment 6 Roan Kattouw 2009-09-23 11:38:12 UTC
(In reply to comment #5)
> Facing same issues listed in comment 3.
> 

Could you report the exact Firefox version, OS and URL used? Also, could you try clearing your cache with Ctrl+F5?
Comment 7 Calcey QA 2009-09-29 05:01:54 UTC
Added keyword babaco to the bug
Comment 8 Roan Kattouw 2009-09-29 13:19:16 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > Facing same issues listed in comment 3.
> > 
> 
> Could you report the exact Firefox version, OS and URL used? Also, could you
> try clearing your cache with Ctrl+F5?
> 

Could you confirm that this issue still exists with Firefox 2.0, and could you answer the questions cited above?
Comment 9 Trevor Parscal 2009-09-30 00:31:00 UTC
I also could not reproduce using Windows XP and Firefox 2.0.0.20 - could Firefox 2 on Vista behave different in this way?
Comment 10 Calcey QA 2009-09-30 06:01:49 UTC
Created attachment 6602 [details]
Reproducing Bug: Screen Shots 

Today also I was able to reproduce the bug.
Please find the browser details herewith.

Test Environment ::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1) Gecko/20061010 Firefox/2.0
Time and Date: 	11:29:39 AM - Wednesday, September 30, 2009
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1024 x 768
Screen Color Depth: 	32
Comment 11 Calcey QA 2009-09-30 06:03:36 UTC
Please find the attachment attached herewith.
There I have noted all the required informations to reproduce the bug.
Comment 12 Calcey QA 2009-09-30 06:18:26 UTC
Created attachment 6603 [details]
Browser Version pic

I have attached a screen shot of the browser version.
Comment 13 Naoko Komura 2009-09-30 18:09:19 UTC
Created attachment 6606 [details]
NTOC missing...

Converting screenshot into pdf
Comment 14 Trevor Parscal 2009-10-05 18:11:33 UTC
Created attachment 6630 [details]
Firebug showing javascript error causing the problem

This is FF 2.0 (not 2.0.* - exactly 2.0) running on Vista.
Comment 15 Trevor Parscal 2009-10-06 23:18:03 UTC
After further investigation, it appears that Firefox 2.0, 2.0.0.1, 2.0.0.2, 2.0.0.3 and 2.0.0.4 are not actually compatible with jquery-ui. These very specific browser versions are in extremely low use, especially since Firefox pushes updates very aggressively - so we have chosen to simple blacklist these specific versions until this jquery-ui bug can be solved (may never happen).
Comment 16 Calcey QA 2009-10-13 12:35:23 UTC
agree and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links