Last modified: 2012-04-19 21:43:41 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20605 - Insert, Replace buttons shall be triggered when enter key is pressed
Insert, Replace buttons shall be triggered when enter key is pressed
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal trivial (vote)
: ---
Assigned To: Trevor Parscal
http://usability.wikimedia.org/wiki/R...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-11 20:06 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-11 20:06:50 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1)Open dialog boxes ( Inserting Link, Insert table and Search and Replace)
2)Click Enter button 

<<Nothing happens >>


Expected Outcome ::
Insert, Replace buttons shall be invoked when Enter key is pressed 

Note : Dialogs are closed when Esc is pressed (as expected)


Test Environment (Client) ::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1280 x 800
Screen Color Depth: 	32
Comment 1 Roan Kattouw 2009-09-15 19:42:14 UTC
Fixed in r56391.
Comment 2 Calcey QA 2009-09-18 06:57:41 UTC
Insert, Replace buttons shall be invoked when Enter key is pressed. But user should enter a single value for one of the fields.
Comment 3 Calcey QA 2009-09-18 07:09:06 UTC
Steps to reproduce the new issue:
1) Open a dialog box (Inserting Link or Insert table or Search and Replace window).
2) Give a value to one of a fields and click on the window.
3) Now Click "Enter" button.

<<Nothing happens >>

Expected Outcome ::
Insert, Replace buttons shall be invoked when Enter key is pressed.

Comment 4 Roan Kattouw 2009-09-26 11:25:11 UTC
(In reply to comment #3)
> Steps to reproduce the new issue:
> 1) Open a dialog box (Inserting Link or Insert table or Search and Replace
> window).
> 2) Give a value to one of a fields and click on the window.
> 3) Now Click "Enter" button.
> 
> <<Nothing happens >>
> 
> Expected Outcome ::
> Insert, Replace buttons shall be invoked when Enter key is pressed.
> 

Fixed in r56948. In some browsers (for instance in Chrome), fixing this seems to be impossible because there's no way to catch keypresses on things that aren't textboxes (that I know of).
Comment 5 Calcey QA 2009-09-28 06:17:06 UTC
Tested for all browsers.
Working fine.
Comment 6 Calcey QA 2009-09-29 05:01:53 UTC
Added keyword babaco to the bug
Comment 7 Calcey QA 2009-10-05 06:56:50 UTC
Reproducible this bug on the following browser for 'Insert Table' functionality.

<<Cannot create a table when click 'Enter' key>>

Test Environment::
Browser (User-Agent): 	Opera/9.50 (Macintosh; Intel Mac OS X; U; en)
Time and Date: 	10:36:16 AM - Monday, October 05, 2009
Javascript:	Enabled
Cookies Enabled:	Enabled 
Java Enabled:	Enabled
Comment 8 Roan Kattouw 2009-10-07 19:58:29 UTC
Since we blacklisted Opera < 9.6, bugs for Opera 9.5 are no longer valid. Reclosing as FIXED.
Comment 9 Calcey QA 2009-10-13 12:35:34 UTC
agree and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links