Last modified: 2012-04-19 21:43:30 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20582 - Search & Replace : Cursor shall be moved to replaced text position
Search & Replace : Cursor shall be moved to replaced text position
Status: CLOSED FIXED
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Normal minor (vote)
: ---
Assigned To: Trevor Parscal
http://usability.wikimedia.org/wiki/R...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-10 17:59 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-10 17:59:01 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1) Start Editing an article 
2) Click on Search and Replace icon.
3) Set 'Search for' and 'Replace with' text 
4) Click Replace button 

<<Scroll bar moved to the top of the page>>


Expected Outcome ::
The cursor shall be moved to replaced text and scroll bar shall be moved enabling user to see the changes. 


Test Environment (Client) ::
Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Javascript: 	Enabled
Cookies Enabled: 	Enabled
Java Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 6.0
Screen Width x Height: 	1280 x 800
Screen Color Depth: 	32
Comment 1 Roan Kattouw 2009-09-11 18:12:10 UTC
Fixed in r56194.
Comment 2 Calcey QA 2009-09-29 05:01:49 UTC
Added keyword babaco to the bug
Comment 3 Calcey QA 2009-09-29 06:34:53 UTC
Steps to Reproduce ::
1) Start Editing an article 
2) Click on Search and Replace icon.
3) Set 'Search for' and 'Replace with' text
4) Check all the check boxes (Match case, Treat search string as a regular expression, Replace all occurrences).
5) Click Replace button 

<<Scroll bar moved to a another section of the article>>


Expected Outcome ::
The cursor shall be moved to last replaced text and scroll bar shall be moved
enabling user to see the changes.

Found the bug in 'Firefox Version 3.5.3'.
Comment 4 Roan Kattouw 2009-09-29 08:55:56 UTC
(In reply to comment #3)
> Steps to Reproduce ::
> 1) Start Editing an article 
> 2) Click on Search and Replace icon.
> 3) Set 'Search for' and 'Replace with' text
> 4) Check all the check boxes (Match case, Treat search string as a regular
> expression, Replace all occurrences).
> 5) Click Replace button 
> 
> <<Scroll bar moved to a another section of the article>>
> 
> 
> Expected Outcome ::
> The cursor shall be moved to last replaced text and scroll bar shall be moved
> enabling user to see the changes.
> 
> Found the bug in 'Firefox Version 3.5.3'.
> 

Are you sure this isn't the same issue as bug 20568?
Comment 5 Roan Kattouw 2009-10-09 19:58:33 UTC
Re-closing as FIXED, can't reproduce the behavior reported in comment #3. It could be the same issue as bug 20568 (NTOC misscrolling) though.
Comment 6 Calcey QA 2009-10-14 10:42:11 UTC
agree and close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links