Last modified: 2009-09-10 05:07:10 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20574 - Semi-colon messes up text
Semi-colon messes up text
Status: RESOLVED DUPLICATE of bug 12974
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
unspecified
All All
: Normal enhancement (vote)
: ---
Assigned To: Nobody - You can work on this!
http://en.wikipedia.org/w/index.php?t...
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-10 01:58 UTC by Daedalus969
Modified: 2009-09-10 05:07 UTC (History)
0 users

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Daedalus969 2009-09-10 01:58:25 UTC
The semicolon, inserted in wikilinks messes up the surrounding text, as it bolds it and discounts the semicolon.  It should only do this when it is obviously used for a title, otherwise it messes up templates, like the one linked, when a signature contains a semicolon.  Alternatively, one could try disallowing it's usage in signatures.
Comment 1 Splarka 2009-09-10 05:07:10 UTC
This is happening because of (simplified) {{ucfirst:{{{1}}}}}, this causes a parser function to start a line with a formatting character (semicolon in example given). This is bug 12974 (duping).

The particular template in question uses ucfirst several places unnecessarily (and the one necessary place is in a category link, and there is a work around: {{ucfirst: {{{1}}}}}). I'll ask a sysop to fixit.

*** This bug has been marked as a duplicate of bug 12974 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links