Last modified: 2012-04-19 21:43:40 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 20569 - Navigable TOC: Links are not highlighted when arrrow key is not released
Navigable TOC: Links are not highlighted when arrrow key is not released
Status: CLOSED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
UsabilityInitiative (Other open bugs)
unspecified
PC Windows Vista
: Lowest minor (vote)
: ---
Assigned To: Trevor Parscal
http://prototype.wikimedia.org/en.wik...
:
Depends on:
Blocks: 36111
  Show dependency treegraph
 
Reported: 2009-09-09 19:48 UTC by Calcey QA
Modified: 2012-04-19 21:43 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Calcey QA 2009-09-09 19:48:26 UTC
Reporting against Babaco Release. (Hosted on http://prototype.wikimedia.org)

Steps to Reproduce ::
1)Navigate to a page and click Edit link
2)Click on the first line in the Edit Window
3)Press the down arrow key 
4)Check the table of content without releasing the arrow key

<<The titles are not highlighted as cursor is moved. The title is highlighted when key is released >>

Expected Outcome ::
Moving the cursor from one section to another shall highlight the corresponding section in table of contents


Additional Observations:
This happens for UP Arrow key, Page Down and UP keys too.


Test Environment ::

Browser (User-Agent):  	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.2) Gecko/20090729 Firefox/3.5.2
Javascript: 	Enabled
Cookies Enabled: 	Enabled
CPU class/type: 	OS/CPU Windows NT 5.1
Comment 1 Douglas Gardner 2009-09-09 19:56:17 UTC
I personally feel that I would find it annoying to have more than one thing scrolling at the same time, at different speeds.
Comment 2 Roan Kattouw 2009-09-10 23:25:37 UTC
Not sure this is desired. From reading the code it looked like this was intentional, is that true, Trevor?
Comment 3 Calcey QA 2009-09-11 17:15:09 UTC
Changed the client platform --> PC and OS --> Windows Vista 
Comment 4 Calcey QA 2009-09-29 05:01:48 UTC
Added keyword babaco to the bug
Comment 5 Roan Kattouw 2009-10-30 19:24:04 UTC
Due to performance concerns this is not going to be changed.
Comment 6 Calcey QA 2009-11-03 05:52:16 UTC
Agree and Close

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links