Last modified: 2012-09-07 11:08:56 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 19173 - previews, resized versions of animated gifs do not animate
previews, resized versions of animated gifs do not animate
Status: RESOLVED WONTFIX
Product: MediaWiki
Classification: Unclassified
File management (Other open bugs)
1.18.x
Other Linux
: Low normal (vote)
: ---
Assigned To: Nobody - You can work on this!
https://test2.wikipedia.org/wiki/File...
:
Depends on:
Blocks: gif
  Show dependency treegraph
 
Reported: 2009-06-12 11:17 UTC by dify
Modified: 2012-09-07 11:08 UTC (History)
3 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
sample animated gif (197.47 KB, image/gif)
2009-06-12 11:18 UTC, dify
Details

Description dify 2009-06-12 11:17:11 UTC
Upload animated gif.
Insert image in wiki page i.e. [[File:my_animated.gif|border|260px|right]]
Animation does not work when page is viewed.

ImageMagick is installed and correctly configured in LocalSettings.php:
$wgUseImageMagick = true;
$wgImageMagickConvertCommand = "/usr/bin/convert";

The version is ImageMagick 6.2.8 04/17/08 Q16 so it seems to be up-to-date.

related to bug #1017
https://bugzilla.wikimedia.org/show_bug.cgi?id=1017
Comment 1 dify 2009-06-12 11:18:39 UTC
Created attachment 6221 [details]
sample animated gif

Resized versions of this animated gif works on wikipedia but not on my mediawiki installation.
Comment 2 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-06-12 11:49:27 UTC
Check that the value of $wgMaxAnimatedGifArea is large enough.
Comment 3 dify 2009-06-12 12:54:44 UTC
Thanks, but it does not have any effect. Is was not in LocalSettings.php so I added $wgMaxAnimatedGifArea = "1.0e9"; (far above the default) but this does not resolve the problem. As far as I can tell, my web host has not killed any processes so it must not be a resource problem.
Comment 4 Sumana Harihareswara 2011-07-21 02:42:57 UTC
dify, are you still experiencing this problem in more recent versions of MediaWiki and Firefox?
Comment 5 Sumana Harihareswara 2011-10-08 00:15:26 UTC
I can confirm this as a problem on test2.  The full-resolution version of the animated file animates, but the preview does not and the other resolution/size versions do not.
Comment 6 Derk-Jan Hartman 2012-09-06 19:22:50 UTC
The GIF is bigger than wgMaxAnimatedGifArea (at least on test2) and thus is not thumbnailed. It might be that the thumbs that were observed to be animating on wikipedia as mentioned in comment 1, were generated before wgMaxAnimatedGifArea was introduced.

Works as intended for me. Note that in comment 3, the user set a string. The expected value is however a number, so:

$wgMaxAnimatedGifArea = 1.0e9;
instead of
$wgMaxAnimatedGifArea = "1.0e9";

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links