Last modified: 2012-08-23 16:41:31 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18826 - PNG cannot display thumbnails if the original over 12.5 megapixels
PNG cannot display thumbnails if the original over 12.5 megapixels
Status: RESOLVED DUPLICATE of bug 9497
Product: Wikimedia
Classification: Unclassified
General/Unknown (Other open bugs)
unspecified
All All
: Lowest enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on: 28135
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-18 00:15 UTC by Adam Cuerden
Modified: 2012-08-23 16:41 UTC (History)
6 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Adam Cuerden 2009-05-18 00:15:10 UTC
Can the limit on PNG thumbnailing please be raised? TIFFs are generally twice the filesize of PNGs, cannot display at all well in any modern browser (should one click on the link to the full size image) and, furthermore, don't thumbnail at all, so PNG is still the best choice for restoration, but the 12.5 megapixel lmiot is still in effect, even as the upload limit was raised to 100 megs.

I presume this is simply an arbitrary limit chosen back when the max upload size was much smaller. It's completely untenable now.
Comment 1 Aryeh Gregor (not reading bugmail, please e-mail directly) 2009-05-18 00:18:16 UTC
This doesn't sound like a MediaWiki issue to me at all, it's probably a config option.  If so, it should have Product: Wikimedia.

The limit was most likely chosen to avoid ImageMagick taking too much memory or such.  Comforting though it may be to think otherwise, sysadmins usually don't try to make arbitrary limits to annoy people.
Comment 2 Chad H. 2009-05-18 00:21:48 UTC
Definitely not a MW issue, updating product as such.
Comment 3 Brion Vibber 2009-05-18 18:00:54 UTC
This is due to image thumbnailing of very large non-JPEG images frequently breaking and taking down the whole site's thumbnailing service. In the future we'd like to have better thumbnailing of huge images but this is dependent on new infrastructure.
Comment 4 Adam Cuerden 2009-05-19 02:32:49 UTC
Well, then, can efforts be put into improving this, or, alternatively, to remove the huge grey squares informing people of the problem and replace it with a simple download icon? ~~~~
Comment 5 Mike.lifeguard 2009-05-19 10:34:53 UTC
(In reply to comment #4)
> Well, then, can efforts be put into improving this, or, alternatively, to
> remove the huge grey squares informing people of the problem and replace it
> with a simple download icon? ~~~~
> 

Yes, that's why it's marked as later. We may be seeing progress over the summer: http://socghop.appspot.com/student_project/show/google/gsoc2009/wikimedia/t124025075087
Comment 6 Diederik van Liere 2011-11-29 22:51:06 UTC
Has the GSOC '09 project helped in resolving this issue? Or more generally,has this issue been resolved?
Comment 7 Brion Vibber 2011-11-29 22:52:21 UTC
VipsScaler should handle this: bug 28135. Setting as a blocker on this bug and reopening this.
Comment 8 Brylie Oxley 2012-07-14 20:13:55 UTC
This limit is enabled on the Wikimedia Commons, and is preventing large panoramas from having preview thumbnails. What infrastructure changes would support thumbnail generation for PNGs > 12.5 megapixels?
Comment 9 Derk-Jan Hartman 2012-07-23 11:37:56 UTC
(In reply to comment #8)
> What infrastructure changes would
> support thumbnail generation for PNGs > 12.5 megapixels?

Please see the status of bug 28135
Comment 10 Marco 2012-08-10 10:36:42 UTC
I think this is a dupl. of Bug #9497 !?
Comment 11 Marco 2012-08-23 10:23:09 UTC
(In reply to comment #10)
> I think this is a dupl. of Bug #9497 !?

If so please mark this as "resolved duplicate" because I can't do so.
Comment 12 Derk-Jan Hartman 2012-08-23 16:41:31 UTC

*** This bug has been marked as a duplicate of bug 9497 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links