Last modified: 2013-06-18 14:41:48 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18731 - API: action=help&version shows wrong SVN link for extension modules
API: action=help&version shows wrong SVN link for extension modules
Status: RESOLVED WONTFIX
Product: MediaWiki extensions
Classification: Unclassified
SiteMatrix (Other open bugs)
unspecified
All All
: Low trivial (vote)
: ---
Assigned To: Nobody - You can work on this!
http://de.wikipedia.org/w/api.php?act...
:
: 18732 (view as bug list)
Depends on:
Blocks: noncoreapi
  Show dependency treegraph
 
Reported: 2009-05-09 11:41 UTC by Umherirrender
Modified: 2013-06-18 14:41 UTC (History)
4 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Umherirrender 2009-05-09 11:41:56 UTC
The url to source file of the api module action=sitematrix is wrong:

current file: http://svn.wikimedia.org/viewvc/mediawiki/trunk/phase3/includes/api/SiteMatrix_body.php
that url gives an exception: trunk/phase3/includes/api/SiteMatrix_body.php: unknown location

The right file is: http://svn.wikimedia.org/viewvc/mediawiki/trunk/extensions/SiteMatrix/SiteMatrix_body.php
Comment 1 Roan Kattouw 2009-05-09 11:59:28 UTC
*** Bug 18732 has been marked as a duplicate of this bug. ***
Comment 2 Roan Kattouw 2009-05-09 12:53:29 UTC
Fixed in r50366
Comment 3 Brion Vibber 2009-05-11 17:43:33 UTC
Assumption is not valid; some directories contain extension entry point files with different names. Use the path that's provided in the version information, rather than throwing it away and attempting to guess it again. 
Comment 4 Roan Kattouw 2009-05-11 19:48:51 UTC
(In reply to comment #3)
> Assumption is not valid; some directories contain extension entry point files
> with different names.
Names of the entry point files are not relevant and aren't guessed. The only assumption made is this: if the local path to the file does not contain /includes/api and does contain /extensions , then the path is assumed to be /something/extensions/ExtensionName/whatever.php , which I think is a reasonable assumption to make.

> Use the path that's provided in the version information,
> rather than throwing it away and attempting to guess it again. 
> 
And just how would I get that path?
Comment 5 Max Semenik 2012-12-15 10:02:55 UTC
We don't use SVN anymore, closing.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links