Last modified: 2009-05-18 17:56:54 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18548 - Section titles beginning with URL-escaped characters --> invalid XHTML anchors
Section titles beginning with URL-escaped characters --> invalid XHTML anchors
Status: RESOLVED DUPLICATE of bug 9530
Product: MediaWiki
Classification: Unclassified
Parser (Other open bugs)
1.15.x
All All
: Normal minor (vote)
: ---
Assigned To: Nobody - You can work on this!
http://www.mediawiki.org/wiki/Manual:FAQ
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-21 18:35 UTC by Math
Modified: 2009-05-18 17:56 UTC (History)
2 users (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Math 2009-04-21 18:35:34 UTC
Hello,

A lot of pages generated by MediaWiki are validated by W3C, but if you look at this:

http://validator.w3.org/check?uri=http://www.mediawiki.org/wiki/Manual:FAQ

You can see that there are errors. It's always the same error. You could see it too on some other pages like:
http://fr.wikipedia.org/wiki/Guitare
http://fr.wikipedia.org/wiki/Etats_unis
...

Thanks for your work!
Comment 1 Happy-melon 2009-04-21 19:51:03 UTC
Retitled; it's section titles beginning with URL-escaped characters that are the problem.  XHTML ids must begin with a letter, apparently (http://www.w3.org/TR/html4/types.html#type-name). 
Comment 2 Roan Kattouw 2009-05-18 17:56:54 UTC

*** This bug has been marked as a duplicate of bug 9530 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links