Last modified: 2011-01-25 01:49:22 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18488 - Run refreshCategoryCounts.php on all WMF wikis
Run refreshCategoryCounts.php on all WMF wikis
Status: RESOLVED FIXED
Product: Wikimedia
Classification: Unclassified
Site requests (Other open bugs)
unspecified
All All
: Normal enhancement with 1 vote (vote)
: ---
Assigned To: Nobody - You can work on this!
: shell
Depends on: 17155
Blocks: 16660
  Show dependency treegraph
 
Reported: 2009-04-16 20:10 UTC by Happy-melon
Modified: 2011-01-25 01:49 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments
Adds a new maintenance script refreshCategoryCounts.php (4.04 KB, patch)
2009-04-16 20:10 UTC, Happy-melon
Details

Description Happy-melon 2009-04-16 20:10:56 UTC
Created attachment 6031 [details]
Adds a new maintenance script refreshCategoryCounts.php

Following bug17155, the category population counts on WMF wikis aren't getting any *more* inaccurate, but they also aren't getting any more correct.  A maintenance script needs to be run to refresh the cat_pages, cat_subcats and cat_files fields of the category table.  I *think* that /maintenance/populateCategory.php would work, but that's not really what it was designed for, and it's certainly not the most efficient way of doing it.  I've adapted it into a new script.  So the "patch need-review" keywords are for someone to check that I haven't made some silly mistake on the patch, and commit it to svn.  Then the "shell" is for someone to run it on all WMF wikis.  If Simetrical did his job properly (:D) it should be easy on the servers.
Comment 1 Max Semenik 2010-05-10 15:49:47 UTC
Maintenance script committed in r66140
Comment 2 Roan Kattouw 2010-05-12 14:08:08 UTC
I've run this script on all wikis except Commons over the past 2 days. Attempting to run it on Commons during peak time results in a database deadlock error before it even gets to 1000 categories, presumably because there's so much category-related activity going on on Commons. I will see about running it at a quieter time.
Comment 3 Roan Kattouw 2010-05-13 11:29:47 UTC
Made a modification suggested by Aryeh Gregor and ran the script on Commons this morning (UTC). Completed with only a single deadlock error.

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links