Last modified: 2011-04-30 01:16:44 UTC

Wikimedia Bugzilla is closed!

Wikimedia has migrated from Bugzilla to Phabricator. Bug reports should be created and updated in Wikimedia Phabricator instead. Please create an account in Phabricator and add your Bugzilla email address to it.
Wikimedia Bugzilla is read-only. If you try to edit or create any bug report in Bugzilla you will be shown an intentional error message.
In order to access the Phabricator task corresponding to a Bugzilla report, just remove "static-" from its URL.
You could still run searches in Bugzilla or access your list of votes but bug reports will obviously not be up-to-date in Bugzilla.
Bug 18439 - Special:AllMessages crashes X or KDE
Special:AllMessages crashes X or KDE
Status: RESOLVED DUPLICATE of bug 16497
Product: MediaWiki
Classification: Unclassified
Special pages (Other open bugs)
1.14.x
All Linux
: Normal critical (vote)
: ---
Assigned To: Nobody - You can work on this!
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-12 18:16 UTC by Dan Barrett
Modified: 2011-04-30 01:16 UTC (History)
1 user (show)

See Also:
Web browser: ---
Mobile Platform: ---
Assignee Huggle Beta Tester: ---


Attachments

Description Dan Barrett 2009-04-12 18:16:47 UTC
On a fresh install of MediaWiki 1.14.0 (no extensions installed), I displayed Special:AllMessages.  My client system's X/KDE session immediately terminated and I saw the KDE login prompt.

I was able to reproduce this 2 more times.  But not consistently.

The system that crashed is super-stable; no crashes like this previously in over a year.

Server platform where MediaWiki was installed:

MediaWiki	1.14.0
PHP	5.2.6 (cgi-fcgi)
MySQL	5.0.67-community
Apache - unknown version
No extensions installed

Client platform where I experienced the crash:

- Firefox 3.0.5 
- Ubuntu Linux (kernel 2.6.22-16-generic)
- KDE 3.5.8

The only system messages I'd edited on the MediaWiki side were:

Common.css
Loginreqpagetext
Logouttext
Mainpage
Mainpage-description
Sidebar
Userlogin

with no weird characters of any kind -- just ASCII.
Comment 1 Roan Kattouw 2009-04-12 18:19:15 UTC
Yes, Special:Allmessages is too big, that's a known bug (see duplicate notice). The fact that KDE crashes because of it is KDE's fault, though: web pages can be huge, and clients should deal with that appropriately.

*** This bug has been marked as a duplicate of bug 16497 ***

Note You need to log in before you can comment on or make changes to this bug.


Navigation
Links